summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-26 21:46:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-26 21:46:40 +0200
commit6f0fdea56551c58b2a2cea3308892622975e1cc8 (patch)
tree73f1b421ec39af1612cb540458bc7b363aca03f5 /dev-python/pillow
parentdev-python/pyproj: Remove old (diff)
downloadgentoo-6f0fdea56551c58b2a2cea3308892622975e1cc8.tar.gz
gentoo-6f0fdea56551c58b2a2cea3308892622975e1cc8.tar.bz2
gentoo-6f0fdea56551c58b2a2cea3308892622975e1cc8.zip
dev-python/pillow: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/Manifest1
-rw-r--r--dev-python/pillow/pillow-8.1.2.ebuild99
2 files changed, 0 insertions, 100 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index 1bc2debb6adf..4bb03cd2cb31 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -1,2 +1 @@
-DIST pillow-8.1.2.tar.gz 45217041 BLAKE2B dbc7fb5c426c6a8f0efd218db5cd404c6b6a603054b36125ea687c69cca78ddd2e58712e8fe94460978bffe6bc059e5819d7ac6371bad11ee8fc1df445495c70 SHA512 32ffedf8cc8f2c21c241f41938d0521626ea05206d1a762305ac38abedecdf9bc8a6e5e2ded7565340e54797a4395acefb3b4d939ebdde8fc9583a1998bae34d
DIST pillow-8.2.0.tar.gz 47898485 BLAKE2B bd8421a101e0be080f2fab238c3c26a4e1e722738e1036bfbb533f420881ea638016ac56e9e66ec74a93c6dafc6e4f8807ec3d504400bb675488da00c9c3cb1c SHA512 40e97a54689ca04349d17b69b0e95bb3ef4fde0b60c6c55a2ec76034a5c2a9ebee0b310f68de1636db08786d9b2ad444bf10ac3b42a31404847cc165aa8392ac
diff --git a/dev-python/pillow/pillow-8.1.2.ebuild b/dev-python/pillow/pillow-8.1.2.ebuild
deleted file mode 100644
index 7136f724209a..000000000000
--- a/dev-python/pillow/pillow-8.1.2.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-PYTHON_REQ_USE='tk?,threads(+)'
-
-inherit distutils-r1 toolchain-funcs virtualx
-
-MY_PN=Pillow
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python Imaging Library (fork)"
-HOMEPAGE="https://python-pillow.org/"
-SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
-REQUIRED_USE="test? ( jpeg jpeg2k tiff )"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- imagequant? ( media-gfx/libimagequant:0 )
- jpeg? ( virtual/jpeg:0 )
- jpeg2k? ( media-libs/openjpeg:2= )
- lcms? ( media-libs/lcms:2= )
- tiff? ( media-libs/tiff:0=[jpeg,zlib] )
- truetype? ( media-libs/freetype:2= )
- webp? ( media-libs/libwebp:0= )
- xcb? ( x11-libs/libxcb )
- zlib? ( sys-libs/zlib:0= )"
-RDEPEND="${DEPEND}
- dev-python/olefile[${PYTHON_USEDEP}]"
-BDEPEND="
- virtual/pkgconfig
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- media-gfx/imagemagick[png]
- )
-"
-
-python_configure_all() {
- # It's important that these flags are also passed during the install phase
- # as well. Make sure of that if you change the lines below. See bug 661308.
- mydistutilsargs=(
- build_ext
- --disable-platform-guessing
- $(use_enable truetype freetype)
- $(use_enable jpeg)
- $(use_enable jpeg2k jpeg2000)
- $(use_enable lcms)
- $(use_enable tiff)
- $(use_enable imagequant)
- $(use_enable webp)
- $(use_enable webp webpmux)
- $(use_enable xcb)
- $(use_enable zlib)
- )
-
- # setup.py sucks at adding the right toolchain paths but it does
- # accept additional ones from INCLUDE and LIB so set these. You
- # wouldn't normally need these at all as the toolchain should look
- # here anyway but this setup.py does stupid things.
- export \
- INCLUDE=${ESYSROOT}/usr/include \
- LIB=${ESYSROOT}/usr/$(get_libdir)
-
- # We have patched in this env var.
- tc-export PKG_CONFIG
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
- # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
- pytest -vv -p no:relaxed || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- python_doheader src/libImaging/*.h
- distutils-r1_python_install
-}
-
-python_install_all() {
- if use examples ; then
- docinto example
- dodoc docs/example/*
- docompress -x /usr/share/doc/${PF}/example
- fi
- distutils-r1_python_install_all
-}