summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-01 12:44:33 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-01 12:55:42 +0100
commitccae58208009c625e02436655fbd51abbea4da93 (patch)
tree8494e9c83d718ec4d626ab47a6fac1e9a2fd8007 /dev-python/pillow
parentsys-kernel/gentoo-kernel-bin: Rebuild host tooling (diff)
downloadgentoo-ccae58208009c625e02436655fbd51abbea4da93.tar.gz
gentoo-ccae58208009c625e02436655fbd51abbea4da93.tar.bz2
gentoo-ccae58208009c625e02436655fbd51abbea4da93.zip
dev-python/pillow: Bump to 8.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/Manifest1
-rw-r--r--dev-python/pillow/pillow-8.1.1.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index d10c00986040..8c8afa3f651f 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -1 +1,2 @@
DIST pillow-8.1.0.tar.gz 44929704 BLAKE2B 6b8100f26a746c625851521d7aa3696c4de30b05d2debc07cfcc038c1bc1e73ab1136676d22fccdf17b8d0ecfeb21479168580e5f5a93488c50cbaf1c6533d79 SHA512 1014271d29e98c465e6882ed3f2f915f8955f5ada2a762c671a1f79389b25576ead2d144c6eaf42b4777f14438d15979d78d34dc32d984fd7defb53f0d209957
+DIST pillow-8.1.1.tar.gz 44976395 BLAKE2B 208534f3e24d9416360efaab8f802b4d482208fe81d1b39bf8339ddd1fe992b281a59faaadeb5ad5364ff062b1b7b19c3dadc11f9a453d5bd14bbf5170521396 SHA512 d04300442ac33e946bea186d6293516b615059b0f4b1b6ac7a48ce3a2e4e22bce5bc403331be697c022a4c81cb30f943cc33bfda649873c734af7db23afd6b69
diff --git a/dev-python/pillow/pillow-8.1.1.ebuild b/dev-python/pillow/pillow-8.1.1.ebuild
new file mode 100644
index 000000000000..f78d8294761f
--- /dev/null
+++ b/dev-python/pillow/pillow-8.1.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 toolchain-funcs virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://python-pillow.org/"
+SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
+REQUIRED_USE="test? ( jpeg tiff )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ imagequant? ( media-gfx/libimagequant:0 )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2= )
+ tiff? ( media-libs/tiff:0=[jpeg,zlib] )
+ truetype? ( media-libs/freetype:2= )
+ webp? ( media-libs/libwebp:0= )
+ xcb? ( x11-libs/libxcb )
+ zlib? ( sys-libs/zlib:0= )"
+RDEPEND="${DEPEND}
+ dev-python/olefile[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-gfx/imagemagick[png]
+ )
+"
+
+python_configure_all() {
+ # It's important that these flags are also passed during the install phase
+ # as well. Make sure of that if you change the lines below. See bug 661308.
+ mydistutilsargs=(
+ build_ext
+ --disable-platform-guessing
+ $(use_enable truetype freetype)
+ $(use_enable jpeg)
+ $(use_enable jpeg2k jpeg2000)
+ $(use_enable lcms)
+ $(use_enable tiff)
+ $(use_enable imagequant)
+ $(use_enable webp)
+ $(use_enable webp webpmux)
+ $(use_enable xcb)
+ $(use_enable zlib)
+ )
+
+ # setup.py sucks at adding the right toolchain paths but it does
+ # accept additional ones from INCLUDE and LIB so set these. You
+ # wouldn't normally need these at all as the toolchain should look
+ # here anyway but this setup.py does stupid things.
+ export \
+ INCLUDE=${ESYSROOT}/usr/include \
+ LIB=${ESYSROOT}/usr/$(get_libdir)
+
+ # We have patched in this env var.
+ tc-export PKG_CONFIG
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
+ pytest -vv -p no:relaxed || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ python_doheader src/libImaging/*.h
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples ; then
+ docinto example
+ dodoc docs/example/*
+ docompress -x /usr/share/doc/${PF}/example
+ fi
+ distutils-r1_python_install_all
+}