summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-21 12:52:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-21 14:24:46 +0100
commit0b848e52256bbdc323ffa450690cded4ad343320 (patch)
treed157a4618f9dc31e22a19b63db6b4782a4c78d84 /dev-python/pip-run
parentdev-ml/dune: add 3.1.1 (diff)
downloadgentoo-0b848e52256bbdc323ffa450690cded4ad343320.tar.gz
gentoo-0b848e52256bbdc323ffa450690cded4ad343320.tar.bz2
gentoo-0b848e52256bbdc323ffa450690cded4ad343320.zip
dev-python/pip-run: Bump to 8.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip-run')
-rw-r--r--dev-python/pip-run/Manifest1
-rw-r--r--dev-python/pip-run/pip-run-8.8.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index eb892e73d226..a1635d86b145 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1 +1,2 @@
DIST pip-run-8.8.1.gh.tar.gz 22443 BLAKE2B 4f87e3ec9867971916a0d5c463cdae63c7bb95ba457ff6e04101c1c37ea8728e2db2bad805b10bb6843b5ded1cb095d0f493b02c8a6e73aa4b782b849aa5ffb4 SHA512 ae964ca96f0be33fdb33974061e75486c443fda5edf0cf43247e8bd293d9a6a87d2cd421100578ed5179f13c9f46ff10ec730e0b403982da7e8aac22651268ea
+DIST pip-run-8.8.2.gh.tar.gz 22900 BLAKE2B 2dbcd18b46abe12c1020a045578a6548468bba0a098c85b0345dce634c61510d6e02feba356831f8531671eabcbcb5b520f15b23864c69bd708e3e2f0ebd125f SHA512 0250f55b49bb3eec10c78b217285df522bc00475dd9bdc710c107a8569e66b2ae643137da59a07c0f6b5e1254a9a920de3212f6befff245cd797947d3fdf95dc
diff --git a/dev-python/pip-run/pip-run-8.8.2.ebuild b/dev-python/pip-run/pip-run-8.8.2.ebuild
new file mode 100644
index 000000000000..120e2a6d2bb7
--- /dev/null
+++ b/dev-python/pip-run/pip-run-8.8.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+SRC_URI="
+ https://github.com/jaraco/pip-run/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Needs network access, and another test dep nbformat
+ pip_run/tests/test_scripts.py
+)
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}