summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-13 07:21:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-13 08:57:40 +0200
commit15c8b863cb7df19d41725b3447e24cc74cc2c4eb (patch)
treef5513243cdd2e779b34b98fa972167bb181bd404 /dev-python/pip
parentdev-python/cachelib: Bump to 0.3.0 (diff)
downloadgentoo-15c8b863cb7df19d41725b3447e24cc74cc2c4eb.tar.gz
gentoo-15c8b863cb7df19d41725b3447e24cc74cc2c4eb.tar.bz2
gentoo-15c8b863cb7df19d41725b3447e24cc74cc2c4eb.zip
dev-python/pip: Bump to 21.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/Manifest1
-rw-r--r--dev-python/pip/pip-21.2.4.ebuild129
2 files changed, 130 insertions, 0 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index 9f85e139b45d..b92e923de12d 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -2,6 +2,7 @@ DIST pip-21.1.3.tar.gz 8772944 BLAKE2B 4c50fcb7c05e05d11b137d08547d9d55f19687442
DIST pip-21.2.1.tar.gz 8781474 BLAKE2B 6a6a4972de31cea2f9ee2d70df00acec65efe344fa13e56ecf9b2f55125baa2effb30bf25c7649f5f30b2ecf9b5ebb7d32dc0f2dfa101444510c8573bd0c60be SHA512 2fff39703eb387ded66552ee62c2b3e4d18da6e8a904399919a5c51f65ddf1695ad410408fe5370877a1ce9992e7c07e091a1852dfb136ce5580e31fc1c03b81
DIST pip-21.2.2.tar.gz 8785943 BLAKE2B 3e99a4e6e01b6239ff5a45097bbae8ba3459a16d0e78f8da4fc1be0ef5986962d30ea8e376705cd7b88198e324e700d04ee25fc6d1d9faa9bb6a76ae89efd38f SHA512 81ec1819481fa2378404c580a4c60fc48b03ae9bd5c945a3def4af331c530efb19949ab45dcb4be5835673b65299e0245c28c6653f9f60eaf86be472fd31faa1
DIST pip-21.2.3.tar.gz 8786685 BLAKE2B 2629db94e973b40c2b3b75199355b0a23d40681d3a346789ee538c5349eb9dd2d9561448ff546d9b73c2dd8573fca6853327560cce63654150a948a2cf0a657f SHA512 9df888c871040d3812a2bf358013e3af976ede1e6aebf6747527be470674bb55ca1312d54021a7913630c04b09981cf481202c8405faf08b1b37e29272adf547
+DIST pip-21.2.4.tar.gz 8786693 BLAKE2B 02d4cdd3d9feda2d4daaf7552bf86e068d2f040ef9836a128c8dfc36697594d6a7d830cc58dc4f2d42c22fec0230f3055ab8b5b204bfd1fb0b9429e2dd44f537 SHA512 3c018601bca60d865032962deaf0ba4943fc6c3f3d8d69dab65f987737daf7fa91492c8250ab36988d1fa5f22b20608ada88ac1ffde914a7d72485bf5164b45f
DIST setuptools-57.4.0-py3-none-any.whl 819017 BLAKE2B afba86cf9aeea58ee869fdc11bbb192abbf2f89710e468b90dc291fec228ca16202483e36195a5ad4e2b8d210326bc83e2be6ec696ab413d94ffaeb05bb9c030 SHA512 9bf230f4e0e72acab07ab372a6ca05adb3d175a8079d2f73d327c632f3d27b8ee10442d3e60f4c94a6e61d5ba2212fc78187ca6e1717e15bb570bdce4263fd0b
DIST virtualenv-16.7.11.tar.gz 8134533 BLAKE2B ea81e11c210d911bf9576edf7b1754721b270adcc5d9633415d33b8f659149d64932fe2d366200121ec00c266c25dae380e248add438fc357477114eba4dfb4e SHA512 82d0d2a964508511e8e1686703581ff543f65791dc2449d9741d46ea57c4c89673947d2477ba374176f05fcea2a5ca572aa650c61c4f3271c4d73d1ff9d9ff42
DIST wheel-0.36.2-py2.py3-none-any.whl 35046 BLAKE2B bc4e8dab7c74eea34d3b4a813b7eaf6295a99a396a861b6cdd76f743043e89140bad132bdd13e385e8945ce02e0798e1d3ac73fc1b23bde5b2a83e4bb4dd5cdc SHA512 6bb5119b4d3704fe1e3c1eaaa3124edab13f61b46f8a0a8e75974fac4e5b25d8b53606071a03a8d8990ad1cfe2ab247ddea260098df2c0c35ae965be47080284
diff --git a/dev-python/pip/pip-21.2.4.ebuild b/dev-python/pip/pip-21.2.4.ebuild
new file mode 100644
index 000000000000..b33ff901b690
--- /dev/null
+++ b/dev-python/pip/pip-21.2.4.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit bash-completion-r1 distutils-r1
+
+# setuptools & wheel .whl files are required for testing,
+# the exact version is not very important.
+SETUPTOOLS_WHL="setuptools-57.4.0-py3-none-any.whl"
+WHEEL_WHL="wheel-0.36.2-py2.py3-none-any.whl"
+# upstream still requires virtualenv-16 for testing, we are now fetching
+# it directly to avoid blockers with virtualenv-20
+VENV_PV=16.7.11
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="
+ https://pip.pypa.io/en/stable/
+ https://pypi.org/project/pip/
+ https://github.com/pypa/pip/"
+SRC_URI="
+ https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ test? (
+ https://files.pythonhosted.org/packages/py3/s/setuptools/${SETUPTOOLS_WHL}
+ https://files.pythonhosted.org/packages/py2.py3/w/wheel/${WHEEL_WHL}
+ https://github.com/pypa/virtualenv/archive/${VENV_PV}.tar.gz
+ -> virtualenv-${VENV_PV}.tar.gz
+ )
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+SLOT="0"
+IUSE="test vanilla"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/scripttest[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-21.1-no-coverage.patch"
+ )
+ if ! use vanilla; then
+ PATCHES+=( "${FILESDIR}/pip-20.0.2-disable-system-install.patch" )
+ fi
+
+ distutils-r1_python_prepare_all
+
+ if use test; then
+ mkdir tests/data/common_wheels/ || die
+ cp "${DISTDIR}"/{${SETUPTOOLS_WHL},${WHEEL_WHL}} \
+ tests/data/common_wheels/ || die
+ fi
+}
+
+python_test() {
+ if [[ ${EPYTHON} == pypy* ]]; then
+ ewarn "Skipping tests on ${EPYTHON} since they are very broken"
+ return 0
+ fi
+
+ local deselect=(
+ tests/functional/test_install.py::test_double_install_fail
+ tests/functional/test_list.py::test_multiple_exclude_and_normalization
+ 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-download]'
+ 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-install]'
+ 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-list]'
+ 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-wheel]'
+ tests/functional/test_install.py::test_install_pip_does_not_modify_pip_when_satisfied
+ # Internet
+ tests/functional/test_install.py::test_install_editable_with_prefix_setup_cfg
+ )
+
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ tests/lib/test_lib.py::test_correct_pip_version
+ # uses vendored packaging that uses deprecated distutils
+ tests/functional/test_warning.py::test_pip_works_with_warnings_as_errors
+ )
+
+ distutils_install_for_testing
+ pushd "${WORKDIR}/virtualenv-${VENV_PV}" >/dev/null || die
+ distutils_install_for_testing
+ popd >/dev/null || die
+
+ local -x GENTOO_PIP_TESTING=1 \
+ PATH="${TEST_DIR}/scripts:${PATH}" \
+ PYTHONPATH="${TEST_DIR}/lib:${BUILD_DIR}/lib"
+ epytest ${deselect[@]/#/--deselect } -m "not network"
+}
+
+python_install_all() {
+ # Prevent dbus auto-launch
+ # https://bugs.gentoo.org/692178
+ export DBUS_SESSION_BUS_ADDRESS="disabled:"
+
+ local DOCS=( AUTHORS.txt docs/html/**/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ # 'pip completion' command embeds full $0 into completion script, which confuses
+ # 'complete' and causes QA warning when running as "${PYTHON} -m pip".
+ # This trick sets correct $0 while still calling just installed pip.
+ local pipcmd='import sys; sys.argv[0] = "pip"; from pip._internal.cli.main import main; sys.exit(main())'
+
+ ${PYTHON} -c "${pipcmd}" completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ ${PYTHON} -c "${pipcmd}" completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}