summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-01-03 23:28:30 -0500
committerMike Gilbert <floppym@gentoo.org>2017-01-03 23:28:30 -0500
commit698a23d83720989123978eb212b387bc5fe96e4a (patch)
tree3e8016bfbdb82340bce647b478bee529f89b054a /dev-python/pip
parentdev-python/pip: remove old (diff)
downloadgentoo-698a23d83720989123978eb212b387bc5fe96e4a.tar.gz
gentoo-698a23d83720989123978eb212b387bc5fe96e4a.tar.bz2
gentoo-698a23d83720989123978eb212b387bc5fe96e4a.zip
dev-python/pip: disable systemwide installs
Bug: https://bugs.gentoo.org/553762 Package-Manager: Portage-2.3.3_p13, Repoman-2.3.1_p6
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/files/pip-disable-system-install.patch29
-rw-r--r--dev-python/pip/pip-9.0.1-r1.ebuild (renamed from dev-python/pip/pip-9.0.1.ebuild)12
2 files changed, 34 insertions, 7 deletions
diff --git a/dev-python/pip/files/pip-disable-system-install.patch b/dev-python/pip/files/pip-disable-system-install.patch
new file mode 100644
index 000000000000..9e572454315e
--- /dev/null
+++ b/dev-python/pip/files/pip-disable-system-install.patch
@@ -0,0 +1,29 @@
+From 847553da616edabede18c69ba640a32b719b45a8 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Tue, 27 Oct 2015 12:20:44 -0400
+Subject: [PATCH] install: Raise an error to avoid breaking python-exec
+
+Running pip without --target, --root, or --user will result in packages
+being installed systemwide. This has a tendency to break python-exec if
+setuptools gets installed or upgraded.
+---
+ pip/commands/install.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/pip/commands/install.py b/pip/commands/install.py
+index 46cd9f2..36b72f2 100644
+--- a/pip/commands/install.py
++++ b/pip/commands/install.py
+@@ -204,6 +204,9 @@ class InstallCommand(RequirementCommand):
+ )
+ options.ignore_installed = True
+
++ if not options.use_user_site and not options.target_dir and not options.root_path:
++ raise CommandError("(Gentoo) Please run pip with the --user option to avoid breaking python-exec")
++
+ if options.build_dir:
+ options.build_dir = os.path.abspath(options.build_dir)
+
+--
+2.6.2
+
diff --git a/dev-python/pip/pip-9.0.1.ebuild b/dev-python/pip/pip-9.0.1-r1.ebuild
index 8cd1b05c63d7..4affc43d92e2 100644
--- a/dev-python/pip/pip-9.0.1.ebuild
+++ b/dev-python/pip/pip-9.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -58,12 +58,10 @@ RESTRICT="test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-9.0.1-disable-version-check.patch
-
- distutils-r1_src_prepare
- eapply_user
-}
+PATCHES=(
+ "${FILESDIR}/pip-disable-system-install.patch"
+ "${FILESDIR}/${PN}-9.0.1-disable-version-check.patch"
+)
python_install_all() {
local DOCS=( AUTHORS.txt docs/*.rst )