summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-12-02 20:09:00 +0000
committerJustin Lecher <jlec@gentoo.org>2017-12-02 20:09:08 +0000
commit570875337306f6523402a05e76524f1b0c24b09b (patch)
treeb7f43204d1857df153fe2869f7a75fc35c44b0db /dev-python/pipenv
parentdev-python/pew: New package (diff)
downloadgentoo-570875337306f6523402a05e76524f1b0c24b09b.tar.gz
gentoo-570875337306f6523402a05e76524f1b0c24b09b.tar.bz2
gentoo-570875337306f6523402a05e76524f1b0c24b09b.zip
dev-python/pipenv: Fix dependencies
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python/pipenv')
-rw-r--r--dev-python/pipenv/pipenv-8.3.2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pipenv/pipenv-8.3.2.ebuild b/dev-python/pipenv/pipenv-8.3.2.ebuild
index dd7ad3f7639f..3a24ba23ec81 100644
--- a/dev-python/pipenv/pipenv-8.3.2.ebuild
+++ b/dev-python/pipenv/pipenv-8.3.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
inherit distutils-r1
@@ -19,6 +19,10 @@ IUSE="test"
RDEPEND=""
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pew-0.1.26[${PYTHON_USEDEP}]
+ >=dev-python/pip-9.0.1[${PYTHON_USEDEP}]
+ >dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
test? (
dev-python/flake8[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]