summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-01 14:22:08 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-02 12:47:12 +0100
commitd753189c4dbd5b970feeaaedd72d9f8e66ea1a7e (patch)
tree0fbb61e4e152ac6da460eeb49be4d3f4a4129bd1 /dev-python/pkginfo
parentdev-python/sphinx_rtd_theme: Clean old (diff)
downloadgentoo-d753189c4dbd5b970feeaaedd72d9f8e66ea1a7e.tar.gz
gentoo-d753189c4dbd5b970feeaaedd72d9f8e66ea1a7e.tar.bz2
gentoo-d753189c4dbd5b970feeaaedd72d9f8e66ea1a7e.zip
dev-python/pkginfo: Clean old
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/Manifest1
-rw-r--r--dev-python/pkginfo/pkginfo-1.0.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
index 938952673fb7..78477263ebae 100644
--- a/dev-python/pkginfo/Manifest
+++ b/dev-python/pkginfo/Manifest
@@ -1,2 +1 @@
-DIST pkginfo-1.0.tar.gz 24802 SHA256 27b171632c6894ae5d0d5677678dfc4e9b86f3b422eb3db1cc62960b1c9886f0 SHA512 1b0f9ed60b53202deb729fa9261059b7fe1b3e4561f27ad51152e5077c45dd4f47fcb81da45cd2e509b046e9bb05652533ae90de31f93831743a9d35c938b14d WHIRLPOOL 312e3bac0a8e4740a40484f9e77a137479e339b6c472409e890d3ba13059a6637c8c2bb0d8bd4496364d98ff3ac1fe7272d4750560c4cdc1d9735187ede0cd5c
DIST pkginfo-1.2.1.tar.gz 31072 SHA256 ad3f6dfe8a831f96a7b56a588ca874137ca102cc6b79fc9b0a1c3b7ab7320f3c SHA512 8a530a164befdcbc6f1f550e106880e14e9d2c762a5e1055f926ccf0228d9e2312f11598454ef015e97dccb78ac7aeb7309f34279590cd318c19c2bd9a29ed2a WHIRLPOOL 1ab43db82665e0abed88bf59115df726475ba7c611b077803721cd6bfcfcc81120c7a996e8945e74ad18c1ec7f6c9e5a1396df37d4f2c0eca24924f4c22e9ee3
diff --git a/dev-python/pkginfo/pkginfo-1.0.ebuild b/dev-python/pkginfo/pkginfo-1.0.ebuild
deleted file mode 100644
index 511e86c64b5a..000000000000
--- a/dev-python/pkginfo/pkginfo-1.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
-HOMEPAGE="https://pypi.python.org/pypi/pkginfo"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-LICENSE="MIT"
-SLOT="0"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_prepare_all() {
- sed -e 's:SPHINXBUILD = sphinx-build:SPHINXBUILD = /usr/bin/sphinx-build:' \
- -i docs/Makefile || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- pushd pkginfo/tests/ > /dev/null
- for test in test_*.py; do
- ${PYTHON} ${test} || die "${test} failed with Python ${PYTHON_ABI}"
- if [[ $? ]]; then
- einfo "Test ${test} successful"
- else
- die "Test ${test} failed under ${EPYTHON}"
- fi
- done
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/.build/html/. )
- use examples && local EXAMPLES=( docs/examples/. )
- distutils-r1_python_install_all
-}