summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-22 09:05:52 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-22 10:01:27 +0200
commitcedf1814c0393ca88d5118816d5cfbbdd5c767a6 (patch)
tree443eb21538f7261b13f590d948ad14f325c2ab50 /dev-python/platformdirs
parentdev-python/regex: Bump to 2021.8.21 (diff)
downloadgentoo-cedf1814c0393ca88d5118816d5cfbbdd5c767a6.tar.gz
gentoo-cedf1814c0393ca88d5118816d5cfbbdd5c767a6.tar.bz2
gentoo-cedf1814c0393ca88d5118816d5cfbbdd5c767a6.zip
dev-python/platformdirs: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/platformdirs')
-rw-r--r--dev-python/platformdirs/Manifest1
-rw-r--r--dev-python/platformdirs/platformdirs-2.2.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/platformdirs/Manifest b/dev-python/platformdirs/Manifest
index d08dc6baad61..9f95f506c445 100644
--- a/dev-python/platformdirs/Manifest
+++ b/dev-python/platformdirs/Manifest
@@ -1 +1,2 @@
DIST platformdirs-2.0.2.gh.tar.gz 11365 BLAKE2B 53257c69f26dde3a0031c991cd6b5c72b361084342617f5c0590007a11a1d7d6e3c925dd6a8d73d3553cf1cc1d2b9fdf74fd0553d6b8891ef6b21d64bc0e256f SHA512 7cdfbcb4e37f2b4b551f3d685a40780518f9ba9c333cef0664965abaca320a10f6e944f967c0b0ba2d00e80df04b0e1e03426e6d1291e28d8f64128f50ebc1fc
+DIST platformdirs-2.2.0.gh.tar.gz 17674 BLAKE2B 1b8e31033194f5682fb8c06be8268cc1ce6172b2bc9f0bfa0d376ab4387547c03c18d46e7c387eb2c36e5db42c09398c95d75cb32e4c5a59f0c7517e867aa1c1 SHA512 fbf4a6929543f5777576a258592e8065195e4d86d728f5c9b4065d1639d53b1c3c5de23c9d58282c291a7f600107af2de097ca2328f632927b9b773140590510
diff --git a/dev-python/platformdirs/platformdirs-2.2.0.ebuild b/dev-python/platformdirs/platformdirs-2.2.0.ebuild
new file mode 100644
index 000000000000..ca2a1a338088
--- /dev/null
+++ b/dev-python/platformdirs/platformdirs-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE="
+ https://pypi.org/project/platformdirs/
+ https://github.com/platformdirs/platformdirs/"
+SRC_URI="
+ https://github.com/platformdirs/platformdirs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}