summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-27 00:29:28 +0000
committerSam James <sam@gentoo.org>2023-02-27 00:31:08 +0000
commit2f7bd19df1692cf627a1dc2806110d7749c4ea21 (patch)
tree7c93e058f7ce8f9f8a9ac69bed9a5037573f249a /dev-python/pluginbase
parentdev-python/pluginbase: enable py3.11 (diff)
downloadgentoo-2f7bd19df1692cf627a1dc2806110d7749c4ea21.tar.gz
gentoo-2f7bd19df1692cf627a1dc2806110d7749c4ea21.tar.bz2
gentoo-2f7bd19df1692cf627a1dc2806110d7749c4ea21.zip
dev-python/pluginbase: EAPI 8, PEP517, pypi.eclass
Bug: https://bugs.gentoo.org/896812 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pluginbase')
-rw-r--r--dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild b/dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..7b3d8dd18f94
--- /dev/null
+++ b/dev-python/pluginbase/pluginbase-1.0.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Support library for building plugins sytems in Python"
+HOMEPAGE="https://github.com/mitsuhiko/pluginbase"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}