summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-10 18:24:48 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-10 18:31:06 +0200
commit9e23b421a835d0b64807048710c660d36b8a243c (patch)
tree958d8a7e95aa99057ce8f9645b114a054e8167d8 /dev-python/ply/ply-3.8.ebuild
parentdev-db/couchdb: eautoreconf after patching configure.ac (bug 561436) (diff)
downloadgentoo-9e23b421a835d0b64807048710c660d36b8a243c.tar.gz
gentoo-9e23b421a835d0b64807048710c660d36b8a243c.tar.bz2
gentoo-9e23b421a835d0b64807048710c660d36b8a243c.zip
dev-python/ply: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ply/ply-3.8.ebuild')
-rw-r--r--dev-python/ply/ply-3.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/ply/ply-3.8.ebuild b/dev-python/ply/ply-3.8.ebuild
new file mode 100644
index 000000000000..1e5e55f92e4b
--- /dev/null
+++ b/dev-python/ply/ply-3.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Lex-Yacc library"
+HOMEPAGE="http://www.dabeaz.com/ply/ https://pypi.python.org/pypi/ply"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# See bug #458648 for reference
+RESTRICT="test"
+
+DOCS=( ANNOUNCE CHANGES TODO )
+
+PATCHES=( "${FILESDIR}/3.6-picklefile-IOError.patch" )
+
+python_test() {
+ cp -r -l test "${BUILD_DIR}"/ || die
+ cd "${BUILD_DIR}"/test || die
+
+ local t
+ for t in testlex.py testyacc.py; do
+ "${PYTHON}" "${t}" || die "${t} fails with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}