summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-21 05:31:57 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-21 05:31:57 +0100
commit41c7000dca670fa4a14aa2f7eb2475519747497d (patch)
tree4128fa212995306d9a652f11b16d0096ae02c095 /dev-python/pooch
parentdev-python/urwid: Bump to 2.6.2 (diff)
downloadgentoo-41c7000dca670fa4a14aa2f7eb2475519747497d.tar.gz
gentoo-41c7000dca670fa4a14aa2f7eb2475519747497d.tar.bz2
gentoo-41c7000dca670fa4a14aa2f7eb2475519747497d.zip
dev-python/pooch: Bump to 1.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pooch')
-rw-r--r--dev-python/pooch/Manifest1
-rw-r--r--dev-python/pooch/pooch-1.8.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index d4778b578e9e..3b3f6f0cf991 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1 +1,2 @@
DIST pooch-1.8.0.tar.gz 59408 BLAKE2B 07ed7c17e98ef4627f347e9b71355e147f56970fe5f0d709269602796a5ba2d8ffd5ad0ad47a17114d32841b9a7fc3eeab978f8ca9f64d35c89ff35b0aa62279 SHA512 d97e3e1098d1eeee30108affc64ed5a12f679e9122d35494598a03f3a548bb83b57dc54ac5a2c85bc42e664cb90f713bdb55b47b430ff000a722ffad58010497
+DIST pooch-1.8.1.tar.gz 59614 BLAKE2B ff30e6f1a1cc71091d5e822eb0eeda59fb1ff8f53d2dd6dc67dccc955d28f3fa485d03615d544096fdae7786c181a3395b62e3c59212f80b977755e3df0addf0 SHA512 9e78da7839deb443340c925622d5e9b1d7a3f14fdac3eae2528fb91ebf86f88715e8737e869057fe7c703e8423303e15379c07e5d11a7bebd3da63b1ac06ae3f
diff --git a/dev-python/pooch/pooch-1.8.1.ebuild b/dev-python/pooch/pooch-1.8.1.ebuild
new file mode 100644
index 000000000000..c6e63ad9b1a0
--- /dev/null
+++ b/dev-python/pooch/pooch-1.8.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage your Python library's sample data files"
+HOMEPAGE="
+ https://github.com/fatiando/pooch/
+ https://pypi.org/project/pooch/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.5.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Needs network
+ pooch/tests/test_core.py::test_check_availability_invalid_downloader
+ pooch/tests/test_core.py::test_load_registry_from_doi
+ pooch/tests/test_core.py::test_load_registry_from_doi_zenodo_with_slash
+ # dev-python/pytest-localftpserver -> dev-python/pyftpdlib has py3.12 issues
+ # https://github.com/giampaolo/pyftpdlib/issues/560#issuecomment-971377238
+ pooch/tests/test_core.py::test_check_availability_on_ftp
+ pooch/tests/test_downloaders.py::test_invalid_doi_repository
+ pooch/tests/test_downloaders.py::test_doi_url_not_found
+ pooch/tests/test_downloaders.py::test_figshare_url_file_not_found
+ pooch/tests/test_downloaders.py::test_doi_downloader
+)
+
+### docs no included in pypi tarball
+# distutils_enable_sphinx doc \
+# dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver -k "not network"
+}