summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-25 09:24:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-25 09:43:02 +0200
commit748ea31b251f9b7dfa3b38ae120efac7cfd26051 (patch)
tree91acc48f6b032802c97f4ce27f1ad64475057486 /dev-python/pooch
parentdev-python/sphinxcontrib-doxylink: Bump to 1.12.3 (diff)
downloadgentoo-748ea31b251f9b7dfa3b38ae120efac7cfd26051.tar.gz
gentoo-748ea31b251f9b7dfa3b38ae120efac7cfd26051.tar.bz2
gentoo-748ea31b251f9b7dfa3b38ae120efac7cfd26051.zip
dev-python/pooch: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pooch')
-rw-r--r--dev-python/pooch/Manifest1
-rw-r--r--dev-python/pooch/pooch-1.8.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index 00271ecfd23d..45a3c13fae4e 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1 +1,2 @@
DIST pooch-1.7.0.tar.gz 57457 BLAKE2B d85fc3cc707bfa639f46bf75b89dd31714f7a4f64a90ff7a6c92b792a8209e66a5fffb62912a336cd481330c37c0037df116d27ea06808bf02f1039e2aac930b SHA512 60126b893a9a1422aad12349143fbe72e485004f79b06da752f51ae374f375efae693304210c8d62b211433d7ce75fab53a50a6f267b1952df83fdccc2de13a7
+DIST pooch-1.8.0.tar.gz 59408 BLAKE2B 07ed7c17e98ef4627f347e9b71355e147f56970fe5f0d709269602796a5ba2d8ffd5ad0ad47a17114d32841b9a7fc3eeab978f8ca9f64d35c89ff35b0aa62279 SHA512 d97e3e1098d1eeee30108affc64ed5a12f679e9122d35494598a03f3a548bb83b57dc54ac5a2c85bc42e664cb90f713bdb55b47b430ff000a722ffad58010497
diff --git a/dev-python/pooch/pooch-1.8.0.ebuild b/dev-python/pooch/pooch-1.8.0.ebuild
new file mode 100644
index 000000000000..48526d352cdf
--- /dev/null
+++ b/dev-python/pooch/pooch-1.8.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Manage your Python library's sample data files"
+HOMEPAGE="
+ https://github.com/fatiando/pooch/
+ https://pypi.org/project/pooch/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.5.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Needs network
+ pooch/tests/test_core.py::test_check_availability_invalid_downloader
+ pooch/tests/test_core.py::test_load_registry_from_doi
+ pooch/tests/test_core.py::test_load_registry_from_doi_zenodo_with_slash
+ # dev-python/pytest-localftpserver -> dev-python/pyftpdlib has py3.12 issues
+ # https://github.com/giampaolo/pyftpdlib/issues/560#issuecomment-971377238
+ pooch/tests/test_core.py::test_check_availability_on_ftp
+ pooch/tests/test_downloaders.py::test_invalid_doi_repository
+ pooch/tests/test_downloaders.py::test_doi_url_not_found
+ pooch/tests/test_downloaders.py::test_figshare_url_file_not_found
+ pooch/tests/test_downloaders.py::test_doi_downloader
+)
+
+### docs no included in pypi tarball
+# distutils_enable_sphinx doc \
+# dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver -k "not network"
+}