summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:33:03 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit3f588a991ebd7cc1bd3eaa439c4f2eff7a6308fd (patch)
tree73d3889b2c6623b7f40a6e924f0fbbcc329be819 /dev-python/progress
parentdev-python/pretend: Add python3.5 support (diff)
downloadgentoo-3f588a991ebd7cc1bd3eaa439c4f2eff7a6308fd.tar.gz
gentoo-3f588a991ebd7cc1bd3eaa439c4f2eff7a6308fd.tar.bz2
gentoo-3f588a991ebd7cc1bd3eaa439c4f2eff7a6308fd.zip
dev-python/progress: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/progress')
-rw-r--r--dev-python/progress/progress-1.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/progress/progress-1.2-r1.ebuild b/dev-python/progress/progress-1.2-r1.ebuild
new file mode 100644
index 000000000000..ac4092c9ca9e
--- /dev/null
+++ b/dev-python/progress/progress-1.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Easy to use progress bars"
+HOMEPAGE="https://pypi.python.org/pypi/progress https://github.com/verigak/progress/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Not bundled
+RESTRICT="test"
+
+python_test() {
+ "${PYTHON}" test_progress.py || die
+}