summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/progressbar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/progressbar')
-rw-r--r--dev-python/progressbar/Manifest1
-rw-r--r--dev-python/progressbar/files/progressbar-2.3-python3.3.patch94
-rw-r--r--dev-python/progressbar/metadata.xml8
-rw-r--r--dev-python/progressbar/progressbar-2.3-r1.ebuild22
4 files changed, 125 insertions, 0 deletions
diff --git a/dev-python/progressbar/Manifest b/dev-python/progressbar/Manifest
new file mode 100644
index 000000000000..27668abc7966
--- /dev/null
+++ b/dev-python/progressbar/Manifest
@@ -0,0 +1 @@
+DIST progressbar-2.3.tar.gz 9802 SHA256 00a316c1a99b70a803d7430fd088da24f37dbfb64f81c4772b97fbc1e8031de4 SHA512 34357d72f8dabc07f4023077a2062cd98dc8a10b14d40cdd6fadd7713a572214fe3176b8638bb0b4b8ffeaa553fa6259793b0813aca9f7c488c22c11807064c3 WHIRLPOOL 85cec2da09debc238cd83e45111b1ed974e3ab0c91bd76787897667abc967d93c78bd2eb3286e483f40164125d8da92e5437163c79af37940be2aa383d4cb2c3
diff --git a/dev-python/progressbar/files/progressbar-2.3-python3.3.patch b/dev-python/progressbar/files/progressbar-2.3-python3.3.patch
new file mode 100644
index 000000000000..112bcf4b3779
--- /dev/null
+++ b/dev-python/progressbar/files/progressbar-2.3-python3.3.patch
@@ -0,0 +1,94 @@
+# HG changeset patch
+# User Nilton Volpato <nilton@google.com>
+# Date 1348267873 10800
+# Fri Sep 21 19:51:13 2012 -0300
+# Node ID 3c94a3a1ebe1325c7c605cc8f11126dcc632b04d
+# Parent 83ece680e4fe06aa704de4c3a967355db21046d4
+Remove format as a slot attribute, as that is not compatible with python 3.3
+
+diff --git a/progressbar/widgets.py b/progressbar/widgets.py
+--- a/progressbar/widgets.py
++++ b/progressbar/widgets.py
+@@ -81,11 +81,11 @@
+ class Timer(Widget):
+ """Widget which displays the elapsed seconds."""
+
+- __slots__ = ('format',)
++ __slots__ = ('format_string',)
+ TIME_SENSITIVE = True
+
+ def __init__(self, format='Elapsed Time: %s'):
+- self.format = format
++ self.format_string = format
+
+ @staticmethod
+ def format_time(seconds):
+@@ -97,7 +97,7 @@
+ def update(self, pbar):
+ """Updates the widget to show the elapsed time."""
+
+- return self.format % self.format_time(pbar.seconds_elapsed)
++ return self.format_string % self.format_time(pbar.seconds_elapsed)
+
+
+ class ETA(Timer):
+@@ -121,9 +121,9 @@
+ class FileTransferSpeed(Widget):
+ """Widget for showing the transfer speed (useful for file transfers)."""
+
+- format = '%6.2f %s%s/s'
+- prefixes = ' kMGTPEZY'
+- __slots__ = ('unit', 'format')
++ FORMAT = '%6.2f %s%s/s'
++ PREFIXES = ' kMGTPEZY'
++ __slots__ = ('unit',)
+
+ def __init__(self, unit='B'):
+ self.unit = unit
+@@ -138,7 +138,7 @@
+ power = int(math.log(speed, 1000))
+ scaled = speed / 1000.**power
+
+- return self.format % (scaled, self.prefixes[power], self.unit)
++ return self.FORMAT % (scaled, self.PREFIXES[power], self.unit)
+
+
+ class AnimatedMarker(Widget):
+@@ -168,13 +168,13 @@
+ class Counter(Widget):
+ """Displays the current count."""
+
+- __slots__ = ('format',)
++ __slots__ = ('format_string',)
+
+ def __init__(self, format='%d'):
+- self.format = format
++ self.format_string = format
+
+ def update(self, pbar):
+- return self.format % pbar.currval
++ return self.format_string % pbar.currval
+
+
+ class Percentage(Widget):
+@@ -197,9 +197,9 @@
+ 'value': ('currval', None)
+ }
+
+- __slots__ = ('format',)
++ __slots__ = ('format_string',)
+ def __init__(self, format):
+- self.format = format
++ self.format_string = format
+
+ def update(self, pbar):
+ context = {}
+@@ -213,7 +213,7 @@
+ context[name] = transform(value)
+ except: pass
+
+- return self.format % context
++ return self.format_string % context
+
+
+ class SimpleProgress(Widget):
diff --git a/dev-python/progressbar/metadata.xml b/dev-python/progressbar/metadata.xml
new file mode 100644
index 000000000000..fe5274bb9ce5
--- /dev/null
+++ b/dev-python/progressbar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="google-code">python-progressbar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/progressbar/progressbar-2.3-r1.ebuild b/dev-python/progressbar/progressbar-2.3-r1.ebuild
new file mode 100644
index 000000000000..7fd0509485f3
--- /dev/null
+++ b/dev-python/progressbar/progressbar-2.3-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Text progressbar library for python"
+HOMEPAGE="http://code.google.com/p/python-progressbar/ http://pypi.python.org/pypi/progressbar"
+SRC_URI="http://python-${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 BSD )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/progressbar-2.3-python3.3.patch" )