summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-01 14:35:28 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-01 14:35:28 +0100
commit9181775cc513c8de1be3b88d171ae7068389f890 (patch)
treea2eceb262eeb551c310ba7853a68d4743b449f04 /dev-python/prometheus_client/prometheus_client-0.0.19.ebuild
parentdev-util/omake: Bump to 0.10.2 (diff)
downloadgentoo-9181775cc513c8de1be3b88d171ae7068389f890.tar.gz
gentoo-9181775cc513c8de1be3b88d171ae7068389f890.tar.bz2
gentoo-9181775cc513c8de1be3b88d171ae7068389f890.zip
dev-python/prometheus_client: Version bump to 0.0.19
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/prometheus_client/prometheus_client-0.0.19.ebuild')
-rw-r--r--dev-python/prometheus_client/prometheus_client-0.0.19.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/prometheus_client/prometheus_client-0.0.19.ebuild b/dev-python/prometheus_client/prometheus_client-0.0.19.ebuild
new file mode 100644
index 000000000000..58681e0e90e9
--- /dev/null
+++ b/dev-python/prometheus_client/prometheus_client-0.0.19.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="https://pypi.python.org/pypi/prometheus_client"
+SRC_URI="https://github.com/prometheus/client_python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+S=${WORKDIR}/client_python-${PV}
+
+RDEPEND="|| ( dev-python/twisted-web dev-python/twisted[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest || die
+}