summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-11-14 20:11:36 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-11-14 20:11:36 +0700
commitb347b9bd331e27377b90ab0aa46be3e8f4174cfc (patch)
treea8e8afaf516058701b832f46eba6b014eaee4269 /dev-python/prompt_toolkit
parentapp-admin/ansible: 2.6.7 and 2.5.11 stable amd64 and x86 (diff)
downloadgentoo-b347b9bd331e27377b90ab0aa46be3e8f4174cfc.tar.gz
gentoo-b347b9bd331e27377b90ab0aa46be3e8f4174cfc.tar.bz2
gentoo-b347b9bd331e27377b90ab0aa46be3e8f4174cfc.zip
dev-python/prompt_toolkit: bump to 2.0.7
Signed-off-by: Andrey Grozin <grozin@gentoo.org> Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-2.0.7.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index a217f76b600e..a04359be9840 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1,2 +1,3 @@
DIST prompt_toolkit-1.0.15.tar.gz 243734 BLAKE2B b27e61bb444360abe95714e2014fcacf2355da0540b21af35cc40cb0f0115d0a3b027236235a89a95c1ec1fa947bf5b88b236b737fab5de78e7bd5fc798aa764 SHA512 10981be2ed8b71d0cd9f663c4de047cec9664d9276968c6eec40dc45b388d1acf8eba07d534369254f178931079bf39b04eb2ceac06aa63a2021ebf62387b2f5
DIST prompt_toolkit-2.0.6.tar.gz 339714 BLAKE2B f969edef98d25930e4d61c1500bb9c8d731dea29e8d154e6baa2ab4045ceaf9d577d46024734a255cc15a4c13685582309e9d2fe7ae3320257f6fd1f9981ada6 SHA512 37082011ee5b8d6fd9febef95c92494ed6108b9ad8c64ac580b69c3464781a2f0dcef5b1c4d06fe309a3036932f7c622042e6b2293acf2ab6f9f2aa3c48d9322
+DIST prompt_toolkit-2.0.7.tar.gz 343267 BLAKE2B eed36fb951bcf8b0663a87eb4e77267246bbc7a6b773ed76d730c04b4dd012434fd0e71e5f558c231fd5ba1e8b3403878106bf3c60f44b7aa3e492a99a622b65 SHA512 4ea8102a50290878248ccc2119eb2b5ae50ad58f466510f8328bc172942f5417abde24393958c910ae0ab2ea4a8caff049b6e7acd8d94e9dbeb97b36c6e2191e
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-2.0.7.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-2.0.7.ebuild
new file mode 100644
index 000000000000..23d9ed1bf792
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-2.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.org/project/prompt_toolkit/ https://github.com/jonathanslenders/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die
+}