summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-09 12:49:15 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-09 12:49:41 +0100
commite80e2bad154f7aae1889980287c4bd590bf127fa (patch)
treefc3a15028e9f4fae2baaf773f2006c25365f12e6 /dev-python/psutil
parentdev-python/nose-exclude: Add python3.5 support (diff)
downloadgentoo-e80e2bad154f7aae1889980287c4bd590bf127fa.tar.gz
gentoo-e80e2bad154f7aae1889980287c4bd590bf127fa.tar.bz2
gentoo-e80e2bad154f7aae1889980287c4bd590bf127fa.zip
dev-python/psutil: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/Manifest1
-rw-r--r--dev-python/psutil/psutil-3.2.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/psutil/Manifest b/dev-python/psutil/Manifest
index 4b29bae09eba..78b23a9c6f28 100644
--- a/dev-python/psutil/Manifest
+++ b/dev-python/psutil/Manifest
@@ -2,3 +2,4 @@ DIST psutil-1.2.1.tar.gz 167397 SHA256 508e4a44c8253a386a0f86d9c9bd4a1b4cbb2f94e
DIST psutil-2.1.3.tar.gz 224008 SHA256 b434c75f01715777391f10f456002e33d0ca14633f96fdbd9ff9139b42d9452c SHA512 12a566c2c53897d858bd75455da8f52d9d9279e28dc0df40594275626f75da716d82c8f67d1fc37df4bd3bc05fef401391cb6c52380c819d1e82fb4edd11f843 WHIRLPOOL 75c8475fc55c5a04858ba8acba0e57f9daa06aed6badf68b484d5ff0dc9c6e52066472bb78350113c1ebe755baf4ab205e347cbb5b2bac3eb4857a2fe0dd8f3f
DIST psutil-3.0.1.tar.gz 241539 SHA256 3f213b9ceed3c3068a973e04d7a8b2a29d1076abcb5ef45382517bfc6b808801 SHA512 38ea65bd91ab2cb6caa88362840d84ad5042fff037ad7b2ff1505e6a014135bd219caea9b48cdb9b5d952eeccc145ee84029f446fbc709c39dc3cc6bd8974846 WHIRLPOOL a536f08c173b606f1e78c27dd8786d469d4dae1ca5e43f997b2c1e74fa129b391d2d2e345f43da0f1a80f1bbd474eb515b62adc60aa78eea9e1b69bfe2ec2edf
DIST psutil-3.1.1.tar.gz 247284 SHA256 d3290bd4a027fa0b3a2e2ee87728056fe49d4112640e2b8c2ea4dd94ba0cf057 SHA512 13393ae083f6881a3e9ac84c0778c622d9a484aeab39705200f9a36386adc2f5a4236db72e1de68aadd90204982ef43ee00c0f3ac61d23fc532d92ab6914d830 WHIRLPOOL f035e7d7de5712e39349806e758afa9d45b7c683b4e3bd9390279900749e3da452df02118ff9a6a047a7c16333d68c6d081dafae0782092b329bc832dd646c97
+DIST psutil-3.2.2.tar.gz 253502 SHA256 f9d848e5bd475ffe7fa3ab1c20d249807e648568af64bb0058412296ec990a0c SHA512 d1649e020fe9ba093c6948252e2eb205005700ac575ec85c696d1bd995af6b3bedad3dab0054859102aa69315905ca3390b268ce4eff5014c746a5a1713a37e5 WHIRLPOOL c4a34d7b3b369d8153de180cc2187921fbd33f26d63086d4868bfc61cf7d1965ae98425a6f9f454987b5df9ff42269a76a012047e679f4387286b127db73769d
diff --git a/dev-python/psutil/psutil-3.2.2.ebuild b/dev-python/psutil/psutil-3.2.2.ebuild
new file mode 100644
index 000000000000..43be6f7afb61
--- /dev/null
+++ b/dev-python/psutil/psutil-3.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.python.org/pypi/psutil/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}