summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-12 14:58:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-12 14:58:43 +0100
commit1c6246664b3c85e74f4573c470c40e4232883e79 (patch)
tree0aa63b2c55d2f6fac7136796366bb08f484a9e83 /dev-python/psycopg
parentsys-fs/eudev: Stabilize 3.2.10 amd64, #769713 (diff)
downloadgentoo-1c6246664b3c85e74f4573c470c40e4232883e79.tar.gz
gentoo-1c6246664b3c85e74f4573c470c40e4232883e79.tar.bz2
gentoo-1c6246664b3c85e74f4573c470c40e4232883e79.zip
dev-python/psycopg: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/Manifest1
-rw-r--r--dev-python/psycopg/psycopg-2.8.5-r1.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index c9341792e5d3..2dbb4f384476 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,2 +1 @@
-DIST psycopg2-2.8.5.tar.gz 380874 BLAKE2B 843321175499bf00b080d3e58ce0d586e674585af4be5a08866b5dbb68256ff9232d3c25e2603a3a0920a6c91927eb9fbb5942acd429be5dab9177c65da0c32e SHA512 d4cf9b94573b90fe56555ea5cf841aa0c4c806770f92f35a7ef2531999bb50f98eb1276e56f1540b5f2695e443bac7e9cb8bbfbd24ed82164f99663259d2da3e
DIST psycopg2-2.8.6.tar.gz 383797 BLAKE2B da0e3f1e143c51c940ba1f51d3e457b492d880ab71267dacd4747444bc767711ccd6c2f54d9e10ce5ad8fae0c3206fb4b6199f267e9bbaf12eb654227f59c2b0 SHA512 1e1d5d8755c6d1a153d84210bf29902afafe853659d709e13abc6bc5772def13779d2394690af1c544384c9c607edc0fe5cf2763244fb346febf9a9e0032b45f
diff --git a/dev-python/psycopg/psycopg-2.8.5-r1.ebuild b/dev-python/psycopg/psycopg-2.8.5-r1.ebuild
deleted file mode 100644
index 1336c8ae6608..000000000000
--- a/dev-python/psycopg/psycopg-2.8.5-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN="${PN}2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="https://www.psycopg.org https://pypi.org/project/psycopg2/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="LGPL-3+"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="debug"
-
-RDEPEND=">=dev-db/postgresql-8.1:*"
-DEPEND="${RDEPEND}"
-
-# Avoid using mxdatetime: https://bugs.gentoo.org/452028
-PATCHES=(
- "${FILESDIR}"/psycopg-2.8.3-avoid-mxdatetime.patch
-)
-
-python_compile() {
- local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
-
- ! python_is_python3 && append-flags -fno-strict-aliasing
-
- distutils-r1_python_compile
-}
-
-python_prepare_all() {
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- initdb -D "${T}"/pgsql || die
- # TODO: random port
- pg_ctl -w -D "${T}"/pgsql start \
- -o "-h '' -k '${T}'" || die
- createdb -h "${T}" psycopg2_test || die
-
- local -x PSYCOPG2_TESTDB_HOST="${T}"
- distutils-r1_src_test
-
- pg_ctl -w -D "${T}"/pgsql stop || die
-}
-
-python_test() {
- "${EPYTHON}" -c "
-import tests
-tests.unittest.main(defaultTest='tests.test_suite')
-" --verbose || die "Tests fail with ${EPYTHON}"
-}