summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-03 13:22:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-03 13:37:52 +0200
commit349546c832a79c9e8c978c3fa2eaa5c48d5eca35 (patch)
tree249e1782f76db30b7ddc48e192a5d50782f283cd /dev-python/psycopg
parentdev-python/m2crypto: Remove old (diff)
downloadgentoo-349546c832a79c9e8c978c3fa2eaa5c48d5eca35.tar.gz
gentoo-349546c832a79c9e8c978c3fa2eaa5c48d5eca35.tar.bz2
gentoo-349546c832a79c9e8c978c3fa2eaa5c48d5eca35.zip
dev-python/psycopg: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/Manifest2
-rw-r--r--dev-python/psycopg/psycopg-2.8.6-r1.ebuild55
-rw-r--r--dev-python/psycopg/psycopg-2.9.ebuild55
3 files changed, 0 insertions, 112 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index 096a6b56a319..b0945f2b68a3 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,3 +1 @@
-DIST psycopg2-2.8.6.tar.gz 383797 BLAKE2B da0e3f1e143c51c940ba1f51d3e457b492d880ab71267dacd4747444bc767711ccd6c2f54d9e10ce5ad8fae0c3206fb4b6199f267e9bbaf12eb654227f59c2b0 SHA512 1e1d5d8755c6d1a153d84210bf29902afafe853659d709e13abc6bc5772def13779d2394690af1c544384c9c607edc0fe5cf2763244fb346febf9a9e0032b45f
DIST psycopg2-2.9.1.tar.gz 379972 BLAKE2B 89a05f0f3e2f426848641bdf07bee1846a5512dd248d7e4eb4723dbc4f7775b00d142217a5cc59e126eeae8e672173b63de3b1152e3bf14dfaccf5fe7149c88d SHA512 478eaeaad98e4521424a0a48d5f0fdba934bb3b682ba111cc37b833cd3c953ad5fbe2a2071d3a9b95c6a447e95de88887ceda5143b63a08703c388f96dd9b4ad
-DIST psycopg2-2.9.tar.gz 379805 BLAKE2B 4e34b9dc28d0922ae9e9f75dd734b961915a032eba0c4b5ea9c4fe82bff4d5d230b37b0efdb25b8423177fdd7e98e69d0ed6ae0eccd731dca212845966b9c0ac SHA512 9787d0d3bb163815a452139bc3fbde93c767431b3e31c77dd534b6a476d1c09a51e2503b0420ac7a3753ef7fa64c13e2643f4bf4aeaeb60f15ea4eefc3538bfa
diff --git a/dev-python/psycopg/psycopg-2.8.6-r1.ebuild b/dev-python/psycopg/psycopg-2.8.6-r1.ebuild
deleted file mode 100644
index f14410ac8a4d..000000000000
--- a/dev-python/psycopg/psycopg-2.8.6-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN="${PN}2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="https://www.psycopg.org https://pypi.org/project/psycopg2/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="LGPL-3+"
-SLOT="2"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="debug test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-db/postgresql-8.1:*"
-DEPEND="${RDEPEND}"
-BDEPEND="
- test? ( >=dev-db/postgresql-8.1[server] )"
-
-python_prepare_all() {
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- initdb -D "${T}"/pgsql || die
- # TODO: random port
- pg_ctl -w -D "${T}"/pgsql start \
- -o "-h '' -k '${T}'" || die
- createdb -h "${T}" psycopg2_test || die
-
- local -x PSYCOPG2_TESTDB_HOST="${T}"
- distutils-r1_src_test
-
- pg_ctl -w -D "${T}"/pgsql stop || die
-}
-
-python_test() {
- "${EPYTHON}" -c "
-import tests
-tests.unittest.main(defaultTest='tests.test_suite')
-" --verbose || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/psycopg/psycopg-2.9.ebuild b/dev-python/psycopg/psycopg-2.9.ebuild
deleted file mode 100644
index 7a7e34f73507..000000000000
--- a/dev-python/psycopg/psycopg-2.9.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN="${PN}2"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL database adapter for Python"
-HOMEPAGE="https://www.psycopg.org https://pypi.org/project/psycopg2/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="LGPL-3+"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="debug test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-db/postgresql-8.1:*"
-DEPEND="${RDEPEND}"
-BDEPEND="
- test? ( >=dev-db/postgresql-8.1[server] )"
-
-python_prepare_all() {
- if use debug; then
- sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- initdb -D "${T}"/pgsql || die
- # TODO: random port
- pg_ctl -w -D "${T}"/pgsql start \
- -o "-h '' -k '${T}'" || die
- createdb -h "${T}" psycopg2_test || die
-
- local -x PSYCOPG2_TESTDB_HOST="${T}"
- distutils-r1_src_test
-
- pg_ctl -w -D "${T}"/pgsql stop || die
-}
-
-python_test() {
- "${EPYTHON}" -c "
-import tests
-tests.unittest.main(defaultTest='tests.test_suite')
-" --verbose || die "Tests fail with ${EPYTHON}"
-}