summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-05-30 15:15:21 -0700
committerZac Medico <zmedico@gentoo.org>2018-05-30 15:16:37 -0700
commit0131ce5db865baa297790072c9d24cdf5d431dda (patch)
tree262a38dd2dcb01a9f9a8030c84087dd718be4014 /dev-python/ptvsd/ptvsd-3.2.1.ebuild
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-0131ce5db865baa297790072c9d24cdf5d431dda.tar.gz
gentoo-0131ce5db865baa297790072c9d24cdf5d431dda.tar.bz2
gentoo-0131ce5db865baa297790072c9d24cdf5d431dda.zip
dev-python/ptvsd: add package
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/ptvsd/ptvsd-3.2.1.ebuild')
-rw-r--r--dev-python/ptvsd/ptvsd-3.2.1.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/ptvsd/ptvsd-3.2.1.ebuild b/dev-python/ptvsd/ptvsd-3.2.1.ebuild
new file mode 100644
index 000000000000..8fb3f60afd06
--- /dev/null
+++ b/dev-python/ptvsd/ptvsd-3.2.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual Studio remote debugging server for Python"
+HOMEPAGE="https://pypi.org/project/ptvsd/ https://github.com/Microsoft/ptvsd/"
+SRC_URI="https://files.pythonhosted.org/packages/59/de/54ad88ba555ce66920165949febf4810359c000c4c73568a6215603b437d/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"