summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 17:29:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-18 17:29:39 +0200
commit0ce384955fcb7147915b86e0bdc86635b4a18434 (patch)
tree58371c09bcd29b57f0edd06025c7cd1a71ed5331 /dev-python/py
parentdev-python/prompt_toolkit: Remove old (diff)
downloadgentoo-0ce384955fcb7147915b86e0bdc86635b4a18434.tar.gz
gentoo-0ce384955fcb7147915b86e0bdc86635b4a18434.tar.bz2
gentoo-0ce384955fcb7147915b86e0bdc86635b4a18434.zip
dev-python/py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/py')
-rw-r--r--dev-python/py/Manifest1
-rw-r--r--dev-python/py/py-1.8.0.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/py/Manifest b/dev-python/py/Manifest
index 8fb96c6c11f1..84b3b6162325 100644
--- a/dev-python/py/Manifest
+++ b/dev-python/py/Manifest
@@ -1,2 +1 @@
-DIST py-1.8.0.tar.gz 205096 BLAKE2B e08554fc3e0bae2e2d4515f075991707af29aa5c39e1387e8f8a7dab25e78c7340d389c79936ddea27b1fb0438ebdee8b5e218bbb48c62089d7fb656b1b6dbe8 SHA512 37b9a66229b834a034d9ba6769a46addf098380b494c1eb863607a52d00b7ec5b9157dd7ac6ffc52535a05006648c775c78716d7f85cf44966065b225be6e95b
DIST py-1.9.0.tar.gz 210098 BLAKE2B d7f9b22ebaedd12534198912c1fa0be80f42e97751701442e060e1c244b06ab82239fe78a3cc7119fa4df5d87ecfd97bfb2568744693d3ffe9824ae1d73e59f9 SHA512 965b2adfe1b13177629ccfcdf6d0a13460683ca7a01d585163deb1af15d926fc86680d9e51660f6cbb8569f822a4d54ce281c029e363d244ddf67e33b102ad0a
diff --git a/dev-python/py/py-1.8.0.ebuild b/dev-python/py/py-1.8.0.ebuild
deleted file mode 100644
index f9c73970d315..000000000000
--- a/dev-python/py/py-1.8.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
-HOMEPAGE="https://pylib.readthedocs.io/en/latest/ https://pypi.org/project/py/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.2-skip-apiwarn-pytest31.patch
- "${FILESDIR}"/${P}-pytest-4.patch
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e 's:intersphinx_mapping:#&:' -i doc/conf.py || die
-
- distutils-r1_python_prepare_all
-
- # broken, and relying on exact assertion strings
- rm testing/code/test_assertion.py || die
- # broken on py3.8, don't seem important
- sed -i -e 's:test_syntaxerror_rerepresentation:_&:' \
- -e 's:test_comments:_&:' \
- testing/code/test_source.py || die
- # broken on py3.9, this package is just dead
- sed -i -e 's:test_excinfo_\(repr\|set\):_&:' \
- -e 's:test_format_excinfo:_&:' \
- -e 's:test_excinfo_str:_&:' \
- testing/code/test_excinfo.py || die
- sed -i -e 's:test_getfslineno:_&:' \
- testing/code/test_source.py || die
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}