summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2019-12-20 14:24:59 -0500
committerRick Farina <zerochaos@gentoo.org>2019-12-20 14:24:59 -0500
commit0815f2cb58f7ea7ab01466e4f91bf1142dc1cde0 (patch)
tree3161b4e5d6b835bb8b2ac35df63204358c3c057a /dev-python/pyFFTW
parentdev-php/PHP_CodeCoverage: Revbump to fix bad autoload file (diff)
downloadgentoo-0815f2cb58f7ea7ab01466e4f91bf1142dc1cde0.tar.gz
gentoo-0815f2cb58f7ea7ab01466e4f91bf1142dc1cde0.tar.bz2
gentoo-0815f2cb58f7ea7ab01466e4f91bf1142dc1cde0.zip
dev-python/pyFFTW: bump and py3.7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'dev-python/pyFFTW')
-rw-r--r--dev-python/pyFFTW/Manifest1
-rw-r--r--dev-python/pyFFTW/pyFFTW-0.11.1.ebuild28
-rw-r--r--dev-python/pyFFTW/pyFFTW-9999.ebuild4
3 files changed, 31 insertions, 2 deletions
diff --git a/dev-python/pyFFTW/Manifest b/dev-python/pyFFTW/Manifest
index 1076f568f083..4305cac4cad7 100644
--- a/dev-python/pyFFTW/Manifest
+++ b/dev-python/pyFFTW/Manifest
@@ -1 +1,2 @@
DIST pyFFTW-0.10.4.tar.gz 97736 BLAKE2B 4d9b7f301e3455af2bc19daf5eb6dc6549df7d50e614d924310f6b20838ad308342ae02b73eff4c9317faba5ff0c0f6dbb7f1ff2ccf1636c6d963a7222d57298 SHA512 d3743e3834ae753898c1abd49762ce5ec6bf808ececb2db93337698ee6b6f4f92969d6a9e61a88230709095ed1b276e722a92330855f349c60b8a9936ab53680
+DIST pyFFTW-0.11.1.tar.gz 144045 BLAKE2B dcf37653e8d5259d8d74282699eb8d9820694f21e092528105e07a8c7e05fe213d908590560e83a5a4ad993716fcf343ef0780126bbd689ee4ff584a01ee6453 SHA512 88769fd65b1a9ba3228a920226ac82f9b4e0a9023b6b73fffc0dc52a8983197e4406c376e89d00888526cfe3a9abb3e15a576daa51ba5bea8e8302514176763a
diff --git a/dev-python/pyFFTW/pyFFTW-0.11.1.ebuild b/dev-python/pyFFTW/pyFFTW-0.11.1.ebuild
new file mode 100644
index 000000000000..ae8b5c9fc97e
--- /dev/null
+++ b/dev-python/pyFFTW/pyFFTW-0.11.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="A pythonic python wrapper around FFTW"
+HOMEPAGE="https://github.com/pyFFTW/pyFFTW"
+
+LICENSE="BSD"
+SLOT="0"
+if [ "${PV}" = "9999" ]; then
+ KEYWORDS=""
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pyFFTW/pyFFTW.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pyFFTW/pyFFTW/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+IUSE=""
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=sci-libs/fftw-3.3:3.0="
+RDEPEND="${DEPEND}"
diff --git a/dev-python/pyFFTW/pyFFTW-9999.ebuild b/dev-python/pyFFTW/pyFFTW-9999.ebuild
index a230885802b6..ae8b5c9fc97e 100644
--- a/dev-python/pyFFTW/pyFFTW-9999.ebuild
+++ b/dev-python/pyFFTW/pyFFTW-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
DESCRIPTION="A pythonic python wrapper around FFTW"