summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-11-03 21:07:29 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-11-03 21:27:28 +0200
commit8034c924f5f2ee668d33cc06162d50a276fa3814 (patch)
treefbf60b335a2075693de739c92f1db4c34e09252a /dev-python/pyFFTW
parentdev-python/pyFFTW: enable tests (diff)
downloadgentoo-8034c924f5f2ee668d33cc06162d50a276fa3814.tar.gz
gentoo-8034c924f5f2ee668d33cc06162d50a276fa3814.tar.bz2
gentoo-8034c924f5f2ee668d33cc06162d50a276fa3814.zip
dev-python/pyFFTW: update live version
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyFFTW')
-rw-r--r--dev-python/pyFFTW/pyFFTW-9999.ebuild31
1 files changed, 22 insertions, 9 deletions
diff --git a/dev-python/pyFFTW/pyFFTW-9999.ebuild b/dev-python/pyFFTW/pyFFTW-9999.ebuild
index c667ef6827f0..8ec87a34fe67 100644
--- a/dev-python/pyFFTW/pyFFTW-9999.ebuild
+++ b/dev-python/pyFFTW/pyFFTW-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
DESCRIPTION="A pythonic python wrapper around FFTW"
@@ -11,7 +11,7 @@ HOMEPAGE="https://github.com/pyFFTW/pyFFTW"
LICENSE="BSD"
SLOT="0"
-if [ "${PV}" = "9999" ]; then
+if [[ "${PV}" = "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/pyFFTW/pyFFTW.git"
else
@@ -19,11 +19,24 @@ else
SRC_URI="https://github.com/pyFFTW/pyFFTW/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
-IUSE=""
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/fftw-3.3:3.0=[threads]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
-DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
- >=sci-libs/fftw-3.3:3.0=[threads]"
-RDEPEND="${DEPEND}
- ${PYTHON_DEPS}"
-BDEPEND="${PYTHON_DEPS}
- dev-python/cython[${PYTHON_USEDEP}]"
+distutils_enable_tests unittest
+
+python_test() {
+ cp -r -l -n test/ "${BUILD_DIR}/lib" || die
+ cd "${BUILD_DIR}/lib" || die
+ eunittest
+ rm -r test/ || die
+}