summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyGPG
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyGPG')
-rw-r--r--dev-python/pyGPG/Manifest1
-rw-r--r--dev-python/pyGPG/metadata.xml16
-rw-r--r--dev-python/pyGPG/pyGPG-0.1.ebuild40
-rw-r--r--dev-python/pyGPG/pyGPG-9999.ebuild46
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/pyGPG/Manifest b/dev-python/pyGPG/Manifest
new file mode 100644
index 000000000000..9a891064f462
--- /dev/null
+++ b/dev-python/pyGPG/Manifest
@@ -0,0 +1 @@
+DIST pyGPG-0.1.tar.gz 15441 SHA256 c699192606652ebe1a369770d00110baa490c74c3d858ad0513ec55f315e7735 SHA512 58a89fbee4311b89c5515ad1bc1d901057e8acdfdbcf36813f50a766374100a62efe456d52263711e5c2f46957791def9343d94f019e413506cfdbd353602060 WHIRLPOOL 24862897737516945cdc8e41ced589f4ef4b64cdd4a92ddae22c07e9252c0cf8779b685b6cd35fac5b3244d0000d9bade98d661c67ac904639ebc142281551c1
diff --git a/dev-python/pyGPG/metadata.xml b/dev-python/pyGPG/metadata.xml
new file mode 100644
index 000000000000..084a922fc0b0
--- /dev/null
+++ b/dev-python/pyGPG/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tools-portage</herd>
+ <maintainer>
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <longdescription>A python interface library for wrapping gnupg's gpg command.
+ It also connects to gpg's status-fd output and makes all the status data
+ available as subclassed namedtuple instances.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">dol-sen/pyGPG</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyGPG/pyGPG-0.1.ebuild b/dev-python/pyGPG/pyGPG-0.1.ebuild
new file mode 100644
index 000000000000..34eadfa645a3
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+inherit distutils-r1
+
+EGIT_REPO_URI="git://github.com/dol-sen/pyGPG.git"
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+SRC_URI="http://dev.gentoo.org/~dolsen/releases/pyGPG/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ "
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyGPG/issues"
+ einfo "I am also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}
diff --git a/dev-python/pyGPG/pyGPG-9999.ebuild b/dev-python/pyGPG/pyGPG-9999.ebuild
new file mode 100644
index 000000000000..1554e4d2eb08
--- /dev/null
+++ b/dev-python/pyGPG/pyGPG-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+
+EGIT_BRANCH="master"
+
+inherit distutils-r1 python-r1 git-2
+
+EGIT_REPO_URI="git://github.com/dol-sen/pyGPG.git"
+
+DESCRIPTION="A python interface wrapper for gnupg's gpg command"
+HOMEPAGE="https://github.com/dol-sen/pyGPG"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyGPG/issues"
+ einfo "I am also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}