summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-10-23 12:40:50 -0400
committerMike Gilbert <floppym@gentoo.org>2017-10-24 13:33:52 -0400
commitaca68ed6f1e01986b21edc552f50c879e073ca9d (patch)
tree018f794e92626142b3ec8f07a54888cf85d6dfb5 /dev-python/pyblake2/pyblake2-0.9.3.ebuild
parentsys-apps/openrc: 0.34 version bump (diff)
downloadgentoo-aca68ed6f1e01986b21edc552f50c879e073ca9d.tar.gz
gentoo-aca68ed6f1e01986b21edc552f50c879e073ca9d.tar.bz2
gentoo-aca68ed6f1e01986b21edc552f50c879e073ca9d.zip
dev-python/pyblake2: select implementation using compiler macros
This eliminates the need for the cpu_flags_x86 USE flags, and resolves a build failure if CFLAGS and cpu_flags_x86 are mismatched. Package-Manager: Portage-2.3.11_p4, Repoman-2.3.3_p62
Diffstat (limited to 'dev-python/pyblake2/pyblake2-0.9.3.ebuild')
-rw-r--r--dev-python/pyblake2/pyblake2-0.9.3.ebuild37
1 files changed, 27 insertions, 10 deletions
diff --git a/dev-python/pyblake2/pyblake2-0.9.3.ebuild b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
index cdfe223ded1f..b0c84ac4968e 100644
--- a/dev-python/pyblake2/pyblake2-0.9.3.ebuild
+++ b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-inherit distutils-r1 flag-o-matic
+inherit distutils-r1 flag-o-matic toolchain-funcs
DESCRIPTION="BLAKE2 hash function extension module"
HOMEPAGE="https://github.com/dchest/pyblake2 https://pypi.python.org/pypi/pyblake2"
@@ -13,18 +13,35 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="CC0-1.0"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_avx cpu_flags_x86_xop"
-python_prepare_all() {
- local impl=REGS
- # note: SSE2 is 2.5x slower than pure REGS, so we ignore it
- use cpu_flags_x86_ssse3 && impl=SSSE3
- # this does not actually do anything but implicitly enabled SSE4.1...
- use cpu_flags_x86_avx && impl=AVX
- use cpu_flags_x86_xop && impl=XOP
+blake2_impl() {
+ local code='
+#if defined(__XOP__)
+ HAVE_XOP
+#elif defined(__AVX__)
+ HAVE_AVX
+#elif defined(__SSSE3__)
+ HAVE_SSSE3
+#elif defined(__SSE2__)
+ HAVE_SSE2
+#endif
+'
+ local res=$($(tc-getCC) -E -P ${CFLAGS} - <<<"${code}")
+
+ case ${res} in
+ *HAVE_XOP*) echo XOP;;
+ # this does not actually do anything but implicitly enabled SSE4.1...
+ *HAVE_AVX*) echo AVX;;
+ *HAVE_SSSE3*) echo SSSE3;;
+ # note: SSE2 is 2.5x slower than pure REGS, so we ignore it
+ #*HAVE_SSE2*) echo SSE2;;
+ *) echo REGS;;
+ esac
+}
+python_prepare_all() {
# uncomment the implementation of choice
- sed -i -e "/BLAKE2_COMPRESS_${impl}/s:^#::" setup.py || die
+ sed -i -e "/BLAKE2_COMPRESS_$(blake2_impl)/s:^#::" setup.py || die
# avoid segfault due to over(?) optimisation
if [[ ${CHOST} == *86*-darwin* ]] ; then