summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-10-25 19:54:00 +0200
committerFabian Groffen <grobian@gentoo.org>2017-10-25 19:54:42 +0200
commit2d91b6bad3708adef98f214c82a6b8b5467e6bbe (patch)
tree23424829b2a771f7f647f8cc1d60a0f69aeaf43e /dev-python/pyblake2
parentgames-fps/urbanterror: Bump to 4.3.2_p20171016. (diff)
downloadgentoo-2d91b6bad3708adef98f214c82a6b8b5467e6bbe.tar.gz
gentoo-2d91b6bad3708adef98f214c82a6b8b5467e6bbe.tar.bz2
gentoo-2d91b6bad3708adef98f214c82a6b8b5467e6bbe.zip
dev-python/pyblake2: drop fugly hack, no longer necessary after cpu features fix
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python/pyblake2')
-rw-r--r--dev-python/pyblake2/pyblake2-0.9.3.ebuild21
1 files changed, 0 insertions, 21 deletions
diff --git a/dev-python/pyblake2/pyblake2-0.9.3.ebuild b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
index b0c84ac4968e..619cb27c3cf6 100644
--- a/dev-python/pyblake2/pyblake2-0.9.3.ebuild
+++ b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
@@ -43,27 +43,6 @@ python_prepare_all() {
# uncomment the implementation of choice
sed -i -e "/BLAKE2_COMPRESS_$(blake2_impl)/s:^#::" setup.py || die
- # avoid segfault due to over(?) optimisation
- if [[ ${CHOST} == *86*-darwin* ]] ; then
- local march=$(get-flag march)
- # expand "native" into the used cpu optmisation
- if [[ ${march} == native ]] ; then
- # we're always on Clang here
- march=$(llc --version | grep "Host CPU:")
- march=${march##*: }
- fi
- # compiling for haswell cpu results in a segfault when used
- # with optimisation >O1, since optimisation here benefits more
- # than cpu specific instructions, reduce to ivybridge level
- case ${march} in
- haswell|broadwell|skylake*)
- local opt=$(get-flag -O)
- [[ ${opt#-O} -gt 1 ]] && \
- replace-flags -march=* -march=ivybridge
- ;;
- esac
- fi
-
distutils-r1_python_prepare_all
}