summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-10-21 10:28:53 +0200
committerMichał Górny <mgorny@gentoo.org>2017-10-21 10:29:48 +0200
commit4db12167a96ac61607585a1642f34de44705e6ab (patch)
tree852354a978de3c7f4be0616b3468a1bf840846bd /dev-python/pyblake2
parentdev-python/pysha3: add some Prefix keywords, bug #634818 (diff)
downloadgentoo-4db12167a96ac61607585a1642f34de44705e6ab.tar.gz
gentoo-4db12167a96ac61607585a1642f34de44705e6ab.tar.bz2
gentoo-4db12167a96ac61607585a1642f34de44705e6ab.zip
dev-python/pyblake2: Support optimized (SSSE3+) variants
Diffstat (limited to 'dev-python/pyblake2')
-rw-r--r--dev-python/pyblake2/pyblake2-0.9.3.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/pyblake2/pyblake2-0.9.3.ebuild b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
index 79f80083bcb7..893bf4757e56 100644
--- a/dev-python/pyblake2/pyblake2-0.9.3.ebuild
+++ b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
@@ -13,12 +13,15 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="CC0-1.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="cpu_flags_x86_ssse3 cpu_flags_x86_avx cpu_flags_x86_xop"
python_prepare_all() {
local impl=REGS
- # note: SSE2 is 2.5x slower than pure REGS...
- # TODO: test other variants on some capable hardware
+ # note: SSE2 is 2.5x slower than pure REGS, so we ignore it
+ use cpu_flags_x86_ssse3 && impl=SSSE3
+ # this does not actually do anything but implicitly enabled SSE4.1...
+ use cpu_flags_x86_avx && impl=AVX
+ use cpu_flags_x86_xop && impl=XOP
# uncomment the implementation of choice
sed -i -e "/BLAKE2_COMPRESS_${impl}/s:^#::" setup.py || die