summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pycanberra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pycanberra')
-rw-r--r--dev-python/pycanberra/Manifest1
-rw-r--r--dev-python/pycanberra/metadata.xml10
-rw-r--r--dev-python/pycanberra/pycanberra-0_pre20130515.ebuild32
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pycanberra/Manifest b/dev-python/pycanberra/Manifest
new file mode 100644
index 000000000000..8ffa7262a477
--- /dev/null
+++ b/dev-python/pycanberra/Manifest
@@ -0,0 +1 @@
+DIST pycanberra-0_pre20130515.zip 14945 SHA256 5d80b30c774bedec1ba37bda6e68d57f8f9f7977590ffe5f5d630a79f348b80f SHA512 9836ed3d5aea9a80a3ffd64ef85b327c7dcdf24793c65010f43139c548d7c77522ab32f407930efed89493509efd117c64ec0fbf4d1d6d567d4d34d12d1936aa WHIRLPOOL d1d81f7cfdbf7097b6fb0e33f127f93524d2921a86bd11d690e4b72ecb0924af9e79686413a68b73dccbc2043ebd6f0b101ea89a715865f2bbd8c25f5a33d8f8
diff --git a/dev-python/pycanberra/metadata.xml b/dev-python/pycanberra/metadata.xml
new file mode 100644
index 000000000000..76493836e911
--- /dev/null
+++ b/dev-python/pycanberra/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <herd>python</herd>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="github">psykoyiko/pycanberra</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycanberra/pycanberra-0_pre20130515.ebuild b/dev-python/pycanberra/pycanberra-0_pre20130515.ebuild
new file mode 100644
index 000000000000..b68acf1c9253
--- /dev/null
+++ b/dev-python/pycanberra/pycanberra-0_pre20130515.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-r1
+
+DESCRIPTION="Basic Python wrapper for libcanberra"
+HOMEPAGE="https://github.com/psykoyiko/pycanberra/"
+PCOMMIT="88c53cd44a626ede3b07dab0b548f8bcfda42867"
+SRC_URI="https://github.com/psykoyiko/pycanberra/archive/${PCOMMIT}.zip -> ${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/libcanberra"
+DEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}/${PN}-${PCOMMIT}"
+
+src_prepare() { :; }
+src_compile() { :; }
+src_install() {
+ python_foreach_impl python_domodule pycanberra.py
+ default
+}