summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2021-09-10 12:28:03 +0200
committerTobias Klausmann <klausman@gentoo.org>2021-09-10 12:28:15 +0200
commit1af1f8563abf561ea0ad53c5d2422a1b69bf8fa7 (patch)
treeecb081e35fc79ce2f847540a0851920124ba828e /dev-python/pycodestyle/pycodestyle-2.6.0.ebuild
parentnet-dns/dnssec-tools: revision bump (diff)
downloadgentoo-1af1f8563abf561ea0ad53c5d2422a1b69bf8fa7.tar.gz
gentoo-1af1f8563abf561ea0ad53c5d2422a1b69bf8fa7.tar.bz2
gentoo-1af1f8563abf561ea0ad53c5d2422a1b69bf8fa7.zip
dev-python/pycodestyle: add DISTUTILS_USE_SETUPTOOLS=no
Closes: https://bugs.gentoo.org/show_bug.cgi?id=812413 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Diffstat (limited to 'dev-python/pycodestyle/pycodestyle-2.6.0.ebuild')
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.6.0.ebuild26
1 files changed, 0 insertions, 26 deletions
diff --git a/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild
deleted file mode 100644
index fc530c8b7c7c..000000000000
--- a/dev-python/pycodestyle/pycodestyle-2.6.0.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Python style guide checker (fka pep8)"
-HOMEPAGE="https://pypi.org/project/pycodestyle/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-distutils_enable_tests setup.py
-distutils_enable_sphinx docs
-
-python_test() {
- PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die
- PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --max-doc-length=72 --testsuite=testsuite || die
- PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py --doctest -v || die
-}