summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-19 12:46:11 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-19 13:45:34 +0100
commit70214372b90cb3e40161aea5372f1e318b7bf51f (patch)
tree142f1b19bb13504f4f34774cfa9c4beda13a5868 /dev-python/pycountry/pycountry-1.20.ebuild
parentdev-python/pyaudio: Bump (diff)
downloadgentoo-70214372b90cb3e40161aea5372f1e318b7bf51f.tar.gz
gentoo-70214372b90cb3e40161aea5372f1e318b7bf51f.tar.bz2
gentoo-70214372b90cb3e40161aea5372f1e318b7bf51f.zip
dev-python/pycountry: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/pycountry/pycountry-1.20.ebuild')
-rw-r--r--dev-python/pycountry/pycountry-1.20.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pycountry/pycountry-1.20.ebuild b/dev-python/pycountry/pycountry-1.20.ebuild
new file mode 100644
index 000000000000..d19095979b11
--- /dev/null
+++ b/dev-python/pycountry/pycountry-1.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://bitbucket.org/flyingcircus/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~ppc ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ if [[ "${EPYTHON}" == pypy || "${EPYTHON}" == pypy3 ]]; then
+ sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+ fi
+ py.test ${PN}/tests/test_general.py || die
+ popd > /dev/null
+}