summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-10-24 11:56:05 -0400
committerMike Gilbert <floppym@gentoo.org>2016-10-24 11:56:59 -0400
commit24ecc278221551081caa262dd1187756414eac1a (patch)
treef2299d2d5d01316717b529171e889a2a6135cbef /dev-python/pycparser
parentdev-python/sepolgen: bump to 2.6 final release (diff)
downloadgentoo-24ecc278221551081caa262dd1187756414eac1a.tar.gz
gentoo-24ecc278221551081caa262dd1187756414eac1a.tar.bz2
gentoo-24ecc278221551081caa262dd1187756414eac1a.zip
dev-python/pycparser: fix file permissions
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/pycparser-2.16-r1.ebuild (renamed from dev-python/pycparser/pycparser-2.16.ebuild)6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/pycparser/pycparser-2.16.ebuild b/dev-python/pycparser/pycparser-2.16-r1.ebuild
index d626ba12ae3b..800fc5a15b7a 100644
--- a/dev-python/pycparser/pycparser-2.16.ebuild
+++ b/dev-python/pycparser/pycparser-2.16-r1.ebuild
@@ -22,6 +22,12 @@ DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+python_prepare_all() {
+ # Bad permissions in tarball
+ chmod -R g+rX,o+rX "${S}" || die
+ distutils-r1_python_prepare_all
+}
+
python_compile() {
distutils-r1_python_compile
pushd "${BUILD_DIR}/lib/pycparser" > /dev/null || die