summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-04 23:11:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-04 23:11:50 +0100
commit7cdd74daeb080447137ea34924b5e5b6aec13736 (patch)
tree3588f7ed97080ccd84faa0482db59e13cbcc20fb /dev-python/pycryptodome
parentnet-libs/ldns: drop 1.8.0-r2 (diff)
downloadgentoo-7cdd74daeb080447137ea34924b5e5b6aec13736.tar.gz
gentoo-7cdd74daeb080447137ea34924b5e5b6aec13736.tar.bz2
gentoo-7cdd74daeb080447137ea34924b5e5b6aec13736.zip
dev-python/pycryptodome: Bump to 3.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycryptodome')
-rw-r--r--dev-python/pycryptodome/Manifest1
-rw-r--r--dev-python/pycryptodome/pycryptodome-3.12.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pycryptodome/Manifest b/dev-python/pycryptodome/Manifest
index 33a931ee4c05..665d61331ce3 100644
--- a/dev-python/pycryptodome/Manifest
+++ b/dev-python/pycryptodome/Manifest
@@ -1 +1,2 @@
DIST pycryptodome-3.11.0.tar.gz 15555515 BLAKE2B fee6a2f2ac0659c82efed2cfdaf7c4d1e4813aaa2203c41c249a7e512a4ec1c955f443022e81847fbfd095cd95f205c054b8c3ef90f4741063c679798cd8c5e5 SHA512 9a6f94a78909b236e9b9224915495f092891951b76836396706c11e8e87717ff84fd92fe04ad641d6a5a0ef1f3b339990d7f21a326e72b95b166a76169240964
+DIST pycryptodome-3.12.0.tar.gz 15130980 BLAKE2B 5eb34a03523652d990ddfdd1eebcbbacea30bffbe4838289c195b07658a98814ebec322aaffbed7b3fa564bc005d52ea1e483dedcb9f40b65d00e50c28d78582 SHA512 67f2a814d74305614fdf9dfb633c4fd9d80d2064119d0ecab24ae52fd8ce4b6de1a1e82c6ba7bcf22fb7db1a5a850adf078e22317b4c07229cd7cb8cb7f1ffd4
diff --git a/dev-python/pycryptodome/pycryptodome-3.12.0.ebuild b/dev-python/pycryptodome/pycryptodome-3.12.0.ebuild
new file mode 100644
index 000000000000..9bf29ac5892e
--- /dev/null
+++ b/dev-python/pycryptodome/pycryptodome-3.12.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://www.pycryptodome.org/
+ https://github.com/Legrandin/pycryptodome/
+ https://pypi.org/project/pycryptodome/"
+SRC_URI="
+ https://github.com/Legrandin/pycryptodome/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ dev-libs/gmp:0=
+ >=dev-libs/libtomcrypt-1.18.2-r1:="
+BDEPEND="
+ virtual/python-cffi[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+ !dev-python/pycrypto"
+
+PATCHES=(
+ "${FILESDIR}/pycryptodome-3.10.1-system-libtomcrypt.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # make sure we're unbundling it correctly
+ rm -r src/libtom || die
+
+ distutils-r1_python_prepare_all
+}