summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-10-13 15:57:39 -0400
committerCraig Andrews <candrews@gentoo.org>2019-10-15 11:57:55 -0400
commitc6c999692c2b28e51bd609f7f1b3138b84f6579e (patch)
tree28b618013b374464df7f2bc8755f4c2c1c0edf0c /dev-python/pydiff
parentdev-python/pydiff: Python 3.7 compatibility (diff)
downloadgentoo-c6c999692c2b28e51bd609f7f1b3138b84f6579e.tar.gz
gentoo-c6c999692c2b28e51bd609f7f1b3138b84f6579e.tar.bz2
gentoo-c6c999692c2b28e51bd609f7f1b3138b84f6579e.zip
dev-python/pydiff: EAPI=7 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-python/pydiff')
-rw-r--r--dev-python/pydiff/pydiff-0.2-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pydiff/pydiff-0.2-r1.ebuild b/dev-python/pydiff/pydiff-0.2-r1.ebuild
new file mode 100644
index 000000000000..01cf57f0c8f7
--- /dev/null
+++ b/dev-python/pydiff/pydiff-0.2-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Diffs two Python files at the bytecode level"
+HOMEPAGE="https://github.com/myint/pydiff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+python_test() {
+ "${PYTHON}" test_pydiff.py || die "Tests failed under ${EPYTHON}"
+}