summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-23 20:12:34 +0200
committerMatt Turner <mattst88@gentoo.org>2020-09-04 10:31:04 -0700
commit395dfa29d0539d49e6f939666d3ba59a8cbe98da (patch)
treedf8d4c4934399477e706543e1f0762ce9d195bb5 /dev-python/pydocstyle
parentsys-kernel/gentoo-kernel-bin: bump to 5.8.6 for arm64 (diff)
downloadgentoo-395dfa29d0539d49e6f939666d3ba59a8cbe98da.tar.gz
gentoo-395dfa29d0539d49e6f939666d3ba59a8cbe98da.tar.bz2
gentoo-395dfa29d0539d49e6f939666d3ba59a8cbe98da.zip
dev-python/pydocstyle: version bump 5.1.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/17240 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/pydocstyle')
-rw-r--r--dev-python/pydocstyle/Manifest1
-rw-r--r--dev-python/pydocstyle/pydocstyle-5.1.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pydocstyle/Manifest b/dev-python/pydocstyle/Manifest
index efa1ceaa89d2..5b227ba9648e 100644
--- a/dev-python/pydocstyle/Manifest
+++ b/dev-python/pydocstyle/Manifest
@@ -1 +1,2 @@
DIST pydocstyle-5.0.2.tar.gz 68063 BLAKE2B 6d7bf04e97c853e50d953342d332847d0e80b080d5ab044f9d444536ed0352ad44402a1af0c3a6f552ec9f3bb3a372a84af2a5bbdaee58bb18dab585cad5dddb SHA512 5ac2e017ae95ff5c7759d6a2cb9ac990f94f668f5fd940792d927cc62628cd036afcf39ab5db6a11100dcca32af344b47f4a7319dd3a47c36367844d0c06d34a
+DIST pydocstyle-5.1.1.tar.gz 70759 BLAKE2B 3cdb519d7f9459a201c9b7bc3002e69dae76b79758b155198b3101c6817c66db01616723e789dd8105d0339d6163fec02ab50db2370b13d3a8d1c5a17ecded6c SHA512 70c7408dfa4c8e54a3abf0548a9af26a7ad7ee0bb76f3a41bf6f2297ce09c13c03ab5e066b1b15404ba6390ddfcacbc5e199d8b73ee74e3b184759d88c8b2a51
diff --git a/dev-python/pydocstyle/pydocstyle-5.1.1.ebuild b/dev-python/pydocstyle/pydocstyle-5.1.1.ebuild
new file mode 100644
index 000000000000..002dcd2f4f59
--- /dev/null
+++ b/dev-python/pydocstyle/pydocstyle-5.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="https://github.com/PyCQA/pydocstyle/"
+SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/snowballstemmer[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/pytest-pep8[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+# Requires network to lookup github issues
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
+
+python_prepare_all() {
+ # These tests call pip.
+ # pip install fails because we are not allowed to do that inside an ebuild.
+ rm "${S}/src/tests/test_integration.py" || die
+
+ distutils-r1_python_prepare_all
+}