summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-19 19:11:08 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-19 19:14:34 -0400
commit9d31b621e12c0c51a6866c1f2235828f75cc66fc (patch)
tree26cefa866fb94d6a01bbff4fc4b818f5e4fe2ef1 /dev-python/pydot/files
parentprofiles: Improve kde-apps/ package removal messages (diff)
downloadgentoo-9d31b621e12c0c51a6866c1f2235828f75cc66fc.tar.gz
gentoo-9d31b621e12c0c51a6866c1f2235828f75cc66fc.tar.bz2
gentoo-9d31b621e12c0c51a6866c1f2235828f75cc66fc.zip
media-gfx/pydot: move to dev-python/pydot
Diffstat (limited to 'dev-python/pydot/files')
-rw-r--r--dev-python/pydot/files/pydot-1.0.23-setup.patch21
-rw-r--r--dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch14
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pydot/files/pydot-1.0.23-setup.patch b/dev-python/pydot/files/pydot-1.0.23-setup.patch
new file mode 100644
index 000000000000..c87cc32b30d1
--- /dev/null
+++ b/dev-python/pydot/files/pydot-1.0.23-setup.patch
@@ -0,0 +1,21 @@
+--- setup.py
++++ setup.py
+@@ -1,9 +1,9 @@
+ #!/usr/bin/env python
+
+ try:
+- from distutils.core import setup
+-except ImportError, excp:
+ from setuptools import setup
++except ImportError, excp:
++ from distutils.core import setup
+
+ import pydot
+ import os
+@@ -31,5 +31,4 @@
+ 'Topic :: Software Development :: Libraries :: Python Modules'],
+ long_description = "\n".join(pydot.__doc__.split('\n')),
+ py_modules = ['pydot', 'dot_parser'],
+- install_requires = ['pyparsing', 'setuptools'],
+- data_files = [('.', ['LICENSE', 'README'])] )
++ install_requires = ['pyparsing', 'setuptools'] )
diff --git a/dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch b/dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch
new file mode 100644
index 000000000000..12a01091223c
--- /dev/null
+++ b/dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch
@@ -0,0 +1,14 @@
+diff -up pydot-1.0.28/dot_parser.py.pyparsing2fix pydot-1.0.28/dot_parser.py
+--- pydot-1.0.28/dot_parser.py.pyparsing2fix 2013-12-09 08:59:24.660145534 -0500
++++ pydot-1.0.28/dot_parser.py 2013-12-09 09:00:10.021222397 -0500
+@@ -25,8 +25,9 @@ from pyparsing import __version__ as pyp
+ from pyparsing import ( nestedExpr, Literal, CaselessLiteral, Word, Upcase, OneOrMore, ZeroOrMore,
+ Forward, NotAny, delimitedList, oneOf, Group, Optional, Combine, alphas, nums,
+ restOfLine, cStyleComment, nums, alphanums, printables, empty, quotedString,
+- ParseException, ParseResults, CharsNotIn, _noncomma, dblQuotedString, QuotedString, ParserElement )
++ ParseException, ParseResults, CharsNotIn, dblQuotedString, QuotedString, ParserElement )
+
++_noncomma = "".join( [ c for c in printables if c != "," ] )
+
+ class P_AttrList:
+