summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-02-14 00:52:55 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2017-03-07 15:17:03 -0500
commit101f920c2b7a15ae65eaffdbab08d5bb794d5ff5 (patch)
treea6c5535c6b628f8376ae7c89620273b80efd7790 /dev-python/pydotplus/pydotplus-2.0.2.ebuild
parentnet-proxy/dante: arm stable (bug 597980). (diff)
downloadgentoo-101f920c2b7a15ae65eaffdbab08d5bb794d5ff5.tar.gz
gentoo-101f920c2b7a15ae65eaffdbab08d5bb794d5ff5.tar.bz2
gentoo-101f920c2b7a15ae65eaffdbab08d5bb794d5ff5.zip
dev-python/pydotplus: new package
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/pydotplus/pydotplus-2.0.2.ebuild')
-rw-r--r--dev-python/pydotplus/pydotplus-2.0.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pydotplus/pydotplus-2.0.2.ebuild b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
new file mode 100644
index 000000000000..5ebcde5602be
--- /dev/null
+++ b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Improved version of the old pydot project"
+HOMEPAGE="http://pydotplus.readthedocs.org/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? (
+# dev-python/flake8[${PYTHON_USEDEP}]
+# dev-python/pytest[${PYTHON_USEDEP}]
+# dev-python/pytest-cov[${PYTHON_USEDEP}]
+# dev-python/sphinx[${PYTHON_USEDEP}]
+# dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+# dev-python/tox[${PYTHON_USEDEP}]
+# )
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ "
+
+#test phase curently disabled, waiting on upstream to include
+#the required files:
+#https://github.com/carlos-jenkins/pydotplus/issues/12
+#python_test() {
+# ${EPYTHON} -m unittest discover || die
+# tox
+#}