summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-11-08 07:53:39 +0100
committerJeroen Roovers <jer@gentoo.org>2015-11-08 07:53:39 +0100
commitb39f2acde24b95c4be5ed1e83c3a0d71fc58ab11 (patch)
treea0f1693f9196f07f1f46fc72a095e55798e408a6 /dev-python/pyfltk/files
parentnet-misc/putty: Stable for PPC64 (bug #565080). (diff)
downloadgentoo-b39f2acde24b95c4be5ed1e83c3a0d71fc58ab11.tar.gz
gentoo-b39f2acde24b95c4be5ed1e83c3a0d71fc58ab11.tar.bz2
gentoo-b39f2acde24b95c4be5ed1e83c3a0d71fc58ab11.zip
dev-python/pyfltk: Old.
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-python/pyfltk/files')
-rw-r--r--dev-python/pyfltk/files/pyfltk-1.3.0-format-security.patch74
-rw-r--r--dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch15
2 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/pyfltk/files/pyfltk-1.3.0-format-security.patch b/dev-python/pyfltk/files/pyfltk-1.3.0-format-security.patch
deleted file mode 100644
index f29b7b3c9221..000000000000
--- a/dev-python/pyfltk/files/pyfltk-1.3.0-format-security.patch
+++ /dev/null
@@ -1,74 +0,0 @@
- python/fltk_wrap.cpp | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/python/fltk_wrap.cpp b/python/fltk_wrap.cpp
-index 9c16f59..ad42e89 100644
---- a/python/fltk_wrap.cpp
-+++ b/python/fltk_wrap.cpp
-@@ -5238,13 +5238,13 @@ PyObject *Fl_get_font_sizes_tmp(PyObject *self, PyObject *args)
-
- const char *fl_vararg_input(const char *label, const char *deflt = 0) {
- const char* result = 0;
-- result = fl_input(label, deflt);
-+ result = fl_input("%s", deflt, label);
- return result;
- };
-
- const char *fl_vararg_password(const char *label, const char *deflt = 0) {
- const char* result = 0;
-- result = fl_password(label, deflt);
-+ result = fl_password("%s", deflt, label);
- return result;
- };
-
-@@ -5282,20 +5282,20 @@ PyObject *Fl_get_font_sizes_tmp(PyObject *self, PyObject *args)
-
- void fl_mt_message(const char* text) {
- Py_BEGIN_ALLOW_THREADS;
-- fl_message(text);
-+ fl_message("%s", text);
- Py_END_ALLOW_THREADS;
- };
-
- void fl_mt_alert(const char* text) {
- Py_BEGIN_ALLOW_THREADS;
-- fl_alert(text);
-+ fl_alert("%s", text);
- Py_END_ALLOW_THREADS;
- };
-
- int fl_mt_ask(const char* text) {
- int status = 0;
- Py_BEGIN_ALLOW_THREADS;
-- status = fl_ask(text);
-+ status = fl_ask("%s", text);
- Py_END_ALLOW_THREADS;
- return status;
- };
-@@ -5303,7 +5303,7 @@ PyObject *Fl_get_font_sizes_tmp(PyObject *self, PyObject *args)
- int fl_mt_choice(const char *q,const char *b0,const char *b1,const char *b2) {
- int status = 0;
- Py_BEGIN_ALLOW_THREADS;
-- status = fl_choice(q, b0, b1, b2);
-+ status = fl_choice("%s", b0, b1, b2, q);
- Py_END_ALLOW_THREADS;
- return status;
- };
-@@ -5311,7 +5311,7 @@ PyObject *Fl_get_font_sizes_tmp(PyObject *self, PyObject *args)
- const char *fl_mt_input(const char *label, const char *deflt = 0) {
- const char* result = 0;
- Py_BEGIN_ALLOW_THREADS;
-- result = fl_input(label, deflt);
-+ result = fl_input("%s", deflt, label);
- Py_END_ALLOW_THREADS;
- return result;
- };
-@@ -5319,7 +5319,7 @@ PyObject *Fl_get_font_sizes_tmp(PyObject *self, PyObject *args)
- const char *fl_mt_password(const char *label, const char *deflt = 0) {
- const char* result = 0;
- Py_BEGIN_ALLOW_THREADS;
-- result = fl_password(label, deflt);
-+ result = fl_password("%s", deflt, label);
- Py_END_ALLOW_THREADS;
- return result;
- };
diff --git a/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch b/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch
deleted file mode 100644
index 9b084616c871..000000000000
--- a/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=375253
-
-http://lipyrary.blogspot.com/2011/09/python-and-linux-kernel-30-sysplatform.html
-
---- setup.py
-+++ setup.py
-@@ -76,7 +76,7 @@
- lib_dir_list = [fltk_lib_dir]
- lib_list = ["fltk", "kernel32", "user32", "gdi32", "winspool", "comdlg32", "Comctl32", "advapi32", "shell32", "oleaut32", "odbc32", "odbccp32", "stdc++", "msvcr71"]
- #link_arg_list=["-Wl,--enable-runtime-pseudo-reloc", "-Wl,--enable-auto-import"]
--elif sys.platform == 'linux2':
-+elif sys.platform.startswith('linux'):
- print "Building for Linux"
- # ugly hack to force distutils to use g++ instead of gcc for linking
- from distutils import sysconfig