summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-08 08:49:42 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-08 08:49:42 +0100
commitf7817bf4b4c48d0bee680b4a64690c15023a0c95 (patch)
treedc51e27bd4fde20176ae2b9ead288521e14f507f /dev-python/pyfltk/files
parentdev-perl/Test-CPAN-Meta: Clean up old. (diff)
downloadgentoo-f7817bf4b4c48d0bee680b4a64690c15023a0c95.tar.gz
gentoo-f7817bf4b4c48d0bee680b4a64690c15023a0c95.tar.bz2
gentoo-f7817bf4b4c48d0bee680b4a64690c15023a0c95.zip
dev-python/pyfltk: Revert "Old."
Restore the last ebuild that supported python2.7. Reverts: b39f2acde2 ("dev-python/pyfltk: Old.")
Diffstat (limited to 'dev-python/pyfltk/files')
-rw-r--r--dev-python/pyfltk/files/pyfltk-1.3.0-format-security.patch74
-rw-r--r--dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch15
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/pyfltk/files/pyfltk-1.3.0-format-security.patch b/dev-python/pyfltk/files/pyfltk-1.3.0-format-security.patch
new file mode 100644
index 000000000000..f29b7b3c9221
--- /dev/null
+++ b/dev-python/pyfltk/files/pyfltk-1.3.0-format-security.patch
@@ -0,0 +1,74 @@
+ python/fltk_wrap.cpp | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/python/fltk_wrap.cpp b/python/fltk_wrap.cpp
+index 9c16f59..ad42e89 100644
+--- a/python/fltk_wrap.cpp
++++ b/python/fltk_wrap.cpp
+@@ -5238,13 +5238,13 @@ PyObject *Fl_get_font_sizes_tmp(PyObject *self, PyObject *args)
+
+ const char *fl_vararg_input(const char *label, const char *deflt = 0) {
+ const char* result = 0;
+- result = fl_input(label, deflt);
++ result = fl_input("%s", deflt, label);
+ return result;
+ };
+
+ const char *fl_vararg_password(const char *label, const char *deflt = 0) {
+ const char* result = 0;
+- result = fl_password(label, deflt);
++ result = fl_password("%s", deflt, label);
+ return result;
+ };
+
+@@ -5282,20 +5282,20 @@ PyObject *Fl_get_font_sizes_tmp(PyObject *self, PyObject *args)
+
+ void fl_mt_message(const char* text) {
+ Py_BEGIN_ALLOW_THREADS;
+- fl_message(text);
++ fl_message("%s", text);
+ Py_END_ALLOW_THREADS;
+ };
+
+ void fl_mt_alert(const char* text) {
+ Py_BEGIN_ALLOW_THREADS;
+- fl_alert(text);
++ fl_alert("%s", text);
+ Py_END_ALLOW_THREADS;
+ };
+
+ int fl_mt_ask(const char* text) {
+ int status = 0;
+ Py_BEGIN_ALLOW_THREADS;
+- status = fl_ask(text);
++ status = fl_ask("%s", text);
+ Py_END_ALLOW_THREADS;
+ return status;
+ };
+@@ -5303,7 +5303,7 @@ PyObject *Fl_get_font_sizes_tmp(PyObject *self, PyObject *args)
+ int fl_mt_choice(const char *q,const char *b0,const char *b1,const char *b2) {
+ int status = 0;
+ Py_BEGIN_ALLOW_THREADS;
+- status = fl_choice(q, b0, b1, b2);
++ status = fl_choice("%s", b0, b1, b2, q);
+ Py_END_ALLOW_THREADS;
+ return status;
+ };
+@@ -5311,7 +5311,7 @@ PyObject *Fl_get_font_sizes_tmp(PyObject *self, PyObject *args)
+ const char *fl_mt_input(const char *label, const char *deflt = 0) {
+ const char* result = 0;
+ Py_BEGIN_ALLOW_THREADS;
+- result = fl_input(label, deflt);
++ result = fl_input("%s", deflt, label);
+ Py_END_ALLOW_THREADS;
+ return result;
+ };
+@@ -5319,7 +5319,7 @@ PyObject *Fl_get_font_sizes_tmp(PyObject *self, PyObject *args)
+ const char *fl_mt_password(const char *label, const char *deflt = 0) {
+ const char* result = 0;
+ Py_BEGIN_ALLOW_THREADS;
+- result = fl_password(label, deflt);
++ result = fl_password("%s", deflt, label);
+ Py_END_ALLOW_THREADS;
+ return result;
+ };
diff --git a/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch b/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch
new file mode 100644
index 000000000000..9b084616c871
--- /dev/null
+++ b/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/show_bug.cgi?id=375253
+
+http://lipyrary.blogspot.com/2011/09/python-and-linux-kernel-30-sysplatform.html
+
+--- setup.py
++++ setup.py
+@@ -76,7 +76,7 @@
+ lib_dir_list = [fltk_lib_dir]
+ lib_list = ["fltk", "kernel32", "user32", "gdi32", "winspool", "comdlg32", "Comctl32", "advapi32", "shell32", "oleaut32", "odbc32", "odbccp32", "stdc++", "msvcr71"]
+ #link_arg_list=["-Wl,--enable-runtime-pseudo-reloc", "-Wl,--enable-auto-import"]
+-elif sys.platform == 'linux2':
++elif sys.platform.startswith('linux'):
+ print "Building for Linux"
+ # ugly hack to force distutils to use g++ instead of gcc for linking
+ from distutils import sysconfig