summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-11-27 14:51:26 +0100
committerLouis Sautier <sbraz@gentoo.org>2019-11-27 15:10:11 +0100
commit75ff0a7a3f85b857de29c22ca735ed02310c2c7d (patch)
treeb70004c74caf7c03509e7e36aea859558deb382c /dev-python/pyftpdlib
parentdev-ruby/selenium-webdriver: amd64 stable (diff)
downloadgentoo-75ff0a7a3f85b857de29c22ca735ed02310c2c7d.tar.gz
gentoo-75ff0a7a3f85b857de29c22ca735ed02310c2c7d.tar.bz2
gentoo-75ff0a7a3f85b857de29c22ca735ed02310c2c7d.zip
dev-python/pyftpdlib: add Python 3.8, skip more failing tests
Also: * switch to distutils_enable_sphinx * add RESTRICT="!test? ( test )" Closes: https://bugs.gentoo.org/701146 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.5-r1.ebuild (renamed from dev-python/pyftpdlib/pyftpdlib-1.5.5.ebuild)35
1 files changed, 13 insertions, 22 deletions
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.5.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.5-r1.ebuild
index 7d37efe8f962..a54faca32ab9 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.5.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.5-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -14,7 +14,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="doc examples ssl test"
+IUSE="examples ssl test"
+RESTRICT="!test? ( test )"
RDEPEND="
ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
@@ -22,10 +23,6 @@ RDEPEND="
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
test? (
${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
@@ -35,17 +32,7 @@ DEPEND="
)
"
-python_prepare_all() {
- sed -i "s/'sphinx.ext.intersphinx'//" docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
python_test() {
# These tests fail when passing additional options to pytest
@@ -55,18 +42,22 @@ python_test() {
local skipped_tests=(
# https://github.com/giampaolo/pyftpdlib/issues/470
# https://bugs.gentoo.org/659108
- test_idle_data_timeout2
+ pyftpdlib/test/test_functional_ssl.py::TestTimeouts::test_idle_data_timeout2
+ pyftpdlib/test/test_functional_ssl.py::TestTimeoutsTLSMixin::test_idle_data_timeout2
# https://github.com/giampaolo/pyftpdlib/issues/471
# https://bugs.gentoo.org/636410
- test_on_incomplete_file_received
+ pyftpdlib/test/test_functional.py::TestCallbacks::test_on_incomplete_file_received
# https://github.com/giampaolo/pyftpdlib/issues/466
# https://bugs.gentoo.org/659786
- test_nlst
+ pyftpdlib/test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
+ # https://github.com/giampaolo/pyftpdlib/issues/512
+ # https://bugs.gentoo.org/701146
+ pyftpdlib/test/test_functional_ssl.py::TestFtpStoreDataTLSMixin::test_rest_on_stor
+ pyftpdlib/test/test_functional_ssl.py::TestFtpStoreDataTLSMixin::test_stor_as cii
)
- skipped_tests=${skipped_tests[@]/%/ or}
# Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
TZ=UTC+1 pytest -vv \
- --ignore ${PN}/test/test_misc.py -k "not (${skipped_tests% or})" \
+ --ignore ${PN}/test/test_misc.py ${skipped_tests[@]/#/--deselect } \
|| die "Tests failed with ${EPYTHON}"
}