summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-07 15:47:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-07 15:52:51 +0200
commit84eb8dc8edd505d3e780b938f84c4e99e3611fe7 (patch)
tree7a4a5c06a0977feadbc7586f37937a2fc71ccdc2 /dev-python/pyftpdlib
parentdev-python/pyftpdlib: Enable 'travis mode' to make tests fail less (diff)
downloadgentoo-84eb8dc8edd505d3e780b938f84c4e99e3611fe7.tar.gz
gentoo-84eb8dc8edd505d3e780b938f84c4e99e3611fe7.tar.bz2
gentoo-84eb8dc8edd505d3e780b938f84c4e99e3611fe7.zip
dev-python/pyftpdlib: Avoid import collisions with localftpserver
Avoid import collisions when pytest-localftpserver plugin is installed. The plugin loads pyftpdlib early, so make sure that pytest is going to load tests from the same directory. Reported by Arthur Zamarin. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
index 21ad58b09d22..4f7cb41422b1 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
@@ -33,6 +33,8 @@ BDEPEND="
distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
python_test() {
+ cd "${BUILD_DIR}"/lib || die
+
# These tests fail when passing additional options to pytest
# so we need to run them separately and not pass any args to pytest
pytest ${PN}/test/test_misc.py || die "Tests failed with ${EPYTHON}"