summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-10 22:35:42 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-10 23:07:51 +0200
commitd2a8804c3475b6dda967ece362f51ccb24fc0fd9 (patch)
treecad0a830baf193b4b5d8b9589a56c4cf58166f8b /dev-python/pyftpdlib
parentprofiles: fix a typo (diff)
downloadgentoo-d2a8804c3475b6dda967ece362f51ccb24fc0fd9.tar.gz
gentoo-d2a8804c3475b6dda967ece362f51ccb24fc0fd9.tar.bz2
gentoo-d2a8804c3475b6dda967ece362f51ccb24fc0fd9.zip
dev-python/pyftpdlib: support Py3.9, remove unnecessary deps
Also make python_test slightly prettier and remove the explicit setuptools dependency. Package-Manager: Portage-3.0.6, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild (renamed from dev-python/pyftpdlib/pyftpdlib-1.5.6.ebuild)22
1 files changed, 6 insertions, 16 deletions
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.6.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
index ef5525f50ada..c98a11ff0494 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.6.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -19,13 +20,10 @@ RESTRICT="!test? ( test )"
RDEPEND="
ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
- dev-python/pysendfile[${PYTHON_USEDEP}]
"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
@@ -40,6 +38,8 @@ python_test() {
pytest ${PN}/test/test_misc.py || die "Tests failed with ${EPYTHON}"
# Some of these tests tend to fail
local skipped_tests=(
+ # Those tests are run separately
+ pyftpdlib/test/test_misc.py
# https://github.com/giampaolo/pyftpdlib/issues/470
# https://bugs.gentoo.org/659108
pyftpdlib/test/test_functional_ssl.py::TestTimeouts::test_idle_data_timeout2
@@ -62,8 +62,7 @@ python_test() {
pyftpdlib/test/test_servers.py::TestFtpAuthentication::test_auth_failed
)
# Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
- TZ=UTC+1 pytest -vv \
- --ignore ${PN}/test/test_misc.py ${skipped_tests[@]/#/--deselect } \
+ TZ=UTC+1 pytest -vv ${skipped_tests[@]/#/--deselect } \
|| die "Tests failed with ${EPYTHON}"
}
@@ -75,12 +74,3 @@ python_install_all() {
fi
distutils-r1_python_install_all
}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] && \
- [[ ${PYTHON_TARGETS} == *python2_7* ]] && \
- ! has_version dev-python/pysendfile ; then
- elog "dev-python/pysendfile is not installed"
- elog "It can considerably speed up file transfers for Python 2"
- fi
-}