summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-15 17:13:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-15 17:13:21 +0200
commit127e5f4249bbfe1a8cd762537838df48e3532e75 (patch)
tree559d0b6d8cdeaf1a1be12f5fcfda4f8347c8cf35 /dev-python/pygame
parentmedia-libs/jpeg: sparc stable wrt bug #727908 (diff)
downloadgentoo-127e5f4249bbfe1a8cd762537838df48e3532e75.tar.gz
gentoo-127e5f4249bbfe1a8cd762537838df48e3532e75.tar.bz2
gentoo-127e5f4249bbfe1a8cd762537838df48e3532e75.zip
dev-python/pygame: Backport test fixes to 1.9.6-r1
Closes: https://bugs.gentoo.org/727890 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/pygame-1.9.6-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/pygame/pygame-1.9.6-r1.ebuild b/dev-python/pygame/pygame-1.9.6-r1.ebuild
index 253ffc048c4a..e47cb5f359bc 100644
--- a/dev-python/pygame/pygame-1.9.6-r1.ebuild
+++ b/dev-python/pygame/pygame-1.9.6-r1.ebuild
@@ -4,10 +4,10 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit flag-o-matic distutils-r1 virtualx
+inherit flag-o-matic distutils-r1
DESCRIPTION="Python bindings for SDL multimedia library"
-HOMEPAGE="http://www.pygame.org/"
+HOMEPAGE="https://www.pygame.org/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
@@ -62,12 +62,10 @@ python_compile() {
distutils-r1_python_compile
}
-src_test() {
- virtx distutils-r1_src_test
-}
-
python_test() {
local -x PYTHONPATH=
+ local -x SDL_VIDEODRIVER=dummy
+ local -x SDL_AUDIODRIVER=disk
distutils_install_for_testing
script -eqc "${EPYTHON} -m pygame.tests" || die
}