summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-20 01:13:57 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-20 01:18:25 +0200
commit03fc3958c52784063a72617cae7291f6b0b6c3bf (patch)
treee358a0c1cd21f32260dcf65a497ab4012f087a84 /dev-python/pygame_sdl2/pygame_sdl2-6.99.6.ebuild
parentdev-util/idea-ultimate: fix trailing whitespace error (diff)
downloadgentoo-03fc3958c52784063a72617cae7291f6b0b6c3bf.tar.gz
gentoo-03fc3958c52784063a72617cae7291f6b0b6c3bf.tar.bz2
gentoo-03fc3958c52784063a72617cae7291f6b0b6c3bf.zip
dev-python/pygame_sdl2: version bump to 6.99.6
Diffstat (limited to 'dev-python/pygame_sdl2/pygame_sdl2-6.99.6.ebuild')
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.6.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.6.ebuild
new file mode 100644
index 000000000000..3496c808fc66
--- /dev/null
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+inherit distutils-r1
+
+DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
+HOMEPAGE="https://github.com/renpy/pygame_sdl2"
+SRC_URI="http://www.renpy.org/dl/${PV}/pygame_sdl2-for-renpy-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image[png,jpeg]
+ media-libs/sdl2-mixer
+ media-libs/sdl2-ttf
+ virtual/jpeg:62
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/pygame-sdl2-for-renpy-${PV}