summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-22 08:10:36 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-22 09:16:23 +0100
commit6aaeb47ed550b2132c4a08ee30ecf2cd3307fda9 (patch)
tree3ffe28fc18a618b41c9555077feb9b34ac4c3dbb /dev-python/pygit2
parentsys-apps/ibm-powerpc-utils: update live ebuild (diff)
downloadgentoo-6aaeb47ed550b2132c4a08ee30ecf2cd3307fda9.tar.gz
gentoo-6aaeb47ed550b2132c4a08ee30ecf2cd3307fda9.tar.bz2
gentoo-6aaeb47ed550b2132c4a08ee30ecf2cd3307fda9.zip
dev-python/pygit2: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-1.0.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 77cf6c59a6e6..30626b83b334 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,2 +1,3 @@
DIST pygit2-0.28.2.tar.gz 496469 BLAKE2B 1173401d4555f6f40eaf5a27d9c0e83214b66afa609f15cc4d689e8c58cc0ae3865b4e6ebb31808d354ecef56f3a74cc777fe42314ef348c39f1f61d82655bc9 SHA512 3f742cdcc9d603c9cc9ef2e0a545da8bcfb555a0bdeea1c73c53a284b43d40ad6b28c87a029578ad7b1c8f2bf56ecd2859dac8dd836474bfc66223ff4af9e8f0
DIST pygit2-1.0.0.tar.gz 501473 BLAKE2B 854f53113bda2ec5c1fd2ba7f2dfc4213d31d3e687fa17d8942b03dd685cd37df28fc8347bd63ede9650de00b980a4cf7aa1196b9feb9a2365e1fc118d187121 SHA512 33296f95aacbfc3cbce275f84c2025767499738495941408de15ac14f822de132995c05c713b815732dbfc3094edf64351d6240e7201e472b3c47035a7532eff
+DIST pygit2-1.0.1.tar.gz 501496 BLAKE2B 6a844a6ecab453f589f407acbd94aba46018a46374ba745ef50e72f4a5eda35103873287af7533ec963a297775eb3703151beec36984dfbcb68d751057c46c78 SHA512 c225204129cdfa41bcc50d76ff219602bfe910cdb77e246c49ecf5265b5a88c5c4803a7d107f4e00c4ec2f0b0d30e1a729d15413bdca8575d6ec23bb9420a90d
diff --git a/dev-python/pygit2/pygit2-1.0.1.ebuild b/dev-python/pygit2/pygit2-1.0.1.ebuild
new file mode 100644
index 000000000000..ade7039d9db1
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-libs/libgit2-0.28*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/def no_network/a \
+ return True' test/utils.py || die
+
+ # we need to move them away to prevent pytest from forcing '..'
+ # for imports
+ mkdir hack || die
+ mv test hack/ || die
+ ln -s hack/test test || die
+}
+
+python_test() {
+ pytest -vv hack/test || die
+}