summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-12-18 07:28:19 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2020-12-18 07:28:19 -0500
commit170bb9968f267f5de0e0c66de0d729a7774a779c (patch)
treebb39bf372dbaa2e20f32e10e2a441e7f735a30bd /dev-python/pygresql
parentapp-admin/sudo: Bump to version 1.9.4_p1 (diff)
downloadgentoo-170bb9968f267f5de0e0c66de0d729a7774a779c.tar.gz
gentoo-170bb9968f267f5de0e0c66de0d729a7774a779c.tar.bz2
gentoo-170bb9968f267f5de0e0c66de0d729a7774a779c.zip
dev-python/pygresql: Bump to 5.2.2
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/pygresql')
-rw-r--r--dev-python/pygresql/Manifest1
-rw-r--r--dev-python/pygresql/pygresql-5.2.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pygresql/Manifest b/dev-python/pygresql/Manifest
index fc6ae068b83b..4ae4f7fa593e 100644
--- a/dev-python/pygresql/Manifest
+++ b/dev-python/pygresql/Manifest
@@ -1,2 +1,3 @@
DIST PyGreSQL-5.2.1.tar.gz 267750 BLAKE2B 6c0d4bcfe4f01bf3214efffa1be274b4a92b5e173094e1afe217aae9a44f88d023b43a2de9d4977fb8ce28d25718cf1cd5d123e8ffc2588f2539b6c03277ec55 SHA512 b304de447c239e4737571b38f0e0761448bd4e313f5b28708aced12cf190f323b85f80d3d87e054b62733add770c7bcd33be644a4f17a96ecc0cf4ab3dba85f3
+DIST PyGreSQL-5.2.2.tar.gz 268818 BLAKE2B 4b74c5496f63208164efa10e70222b63512f3afb928bdc612f9874556ee2084b42a80ba05e9ebc6951c68c1c8a70c71320396aabb20b9d5c00d5edd46e287f3f SHA512 a88af2590a515ece19b7f64796e241c6e7b53c8aef90c6e2ae064298a4c71d44695dcf43e0e84595a704c4fdafb9abe35e1779492d3a9ad3708759215cb188a1
DIST PyGreSQL-5.2.tar.gz 267557 BLAKE2B 92c2c0810a9b763fc2e9fec2e920ca1e21da4eb4ede5f2e20f66fd385ccc623fd9fe74075c6b995c6ea6348df76dcd723c8e4b6d83afdb53c978c02cc5220e49 SHA512 ce1cd29c714ab863dbdc7dde920f8938b115535ae3a0b54c770d7648f05011a716d604eec2d73c321fe2a408e64bcd9208c204856e5ddb0e0675ef7c076e4da7
diff --git a/dev-python/pygresql/pygresql-5.2.2.ebuild b/dev-python/pygresql/pygresql-5.2.2.ebuild
new file mode 100644
index 000000000000..709e1ceeafe2
--- /dev/null
+++ b/dev-python/pygresql/pygresql-5.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.{5..6} {10..13} )
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 postgres
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database"
+HOMEPAGE="https://pygresql.org/"
+SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="${POSTGRES_DEP}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-5.2-CFLAGS.patch )
+
+python_install_all() {
+ local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )
+
+ distutils-r1_python_install_all
+}