summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-02-14 21:06:19 +0100
committerSam James <sam@gentoo.org>2021-02-16 19:19:52 +0000
commit42498dcff76d3e714a374ca102e93fa1974ebc6a (patch)
treea992288fd87138142ea96e90771df7e1fe307e87 /dev-python/pyilmbase
parentmedia-libs/openexr: bump to 2.5.5 (diff)
downloadgentoo-42498dcff76d3e714a374ca102e93fa1974ebc6a.tar.gz
gentoo-42498dcff76d3e714a374ca102e93fa1974ebc6a.tar.bz2
gentoo-42498dcff76d3e714a374ca102e93fa1974ebc6a.zip
dev-python/pyilmbase: bump to 2.5.5
Bug: https://bugs.gentoo.org/770229 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/19470 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyilmbase')
-rw-r--r--dev-python/pyilmbase/Manifest1
-rw-r--r--dev-python/pyilmbase/pyilmbase-2.5.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pyilmbase/Manifest b/dev-python/pyilmbase/Manifest
index 6dcb24547644..a0ec5c5b0e80 100644
--- a/dev-python/pyilmbase/Manifest
+++ b/dev-python/pyilmbase/Manifest
@@ -1,2 +1,3 @@
DIST pyilmbase-2.5.2.tar.gz 27525326 BLAKE2B c48a61513457f2c04f3a512963ae27eaf154933ffe7c6ff3e2d71f27f246ae624a34dbe6f8ab500c51a56898ad0f61e6784f5cd3f9c3df591ce347b46ba4ac88 SHA512 62f98695cf56600303db9c2d13d34cacc1851a103d8ffb7e7ce8c6d9d14e6bf02804836c718ae03e8d685ef3dda0cf7b2130e2d363f8095b22a15bf30d706fab
DIST pyilmbase-2.5.4.tar.gz 27535491 BLAKE2B 8951383d31ceea49202e3b77999d71c261bc9a17433fb65debd446aefd62cc1f6776a4b37fb1161196135a8883a397a94496a2295a2e0d22bc43c59e2ad0eaa5 SHA512 f0fe305987981e0c7e5a854367702585e4935ad37b0e8c10dcbc7468ae3a6d34bf963ec9ec75cc3abe4cf00e359644476b643978d0289dca46c9785a25d3f7f1
+DIST pyilmbase-2.5.5.tar.gz 27536865 BLAKE2B d0c0b2fd39b2cfafb60b6d0de3960063ff62341cf22be519f874c0c83f05cb604c5d503bb8b88514c71c5a54a79afa80a7fd00c2df15ec2193f6b3cffdc117c6 SHA512 e511af26a8fe2175a641fd25d2dcc6ef807e00bee2aff06a4784125f916ffd47fe376fe0621d385b604180a239bbfee063f8ceee3f7b731fde3c38558e9fdcdf
diff --git a/dev-python/pyilmbase/pyilmbase-2.5.5.ebuild b/dev-python/pyilmbase/pyilmbase-2.5.5.ebuild
new file mode 100644
index 000000000000..223f1a8e4a37
--- /dev/null
+++ b/dev-python/pyilmbase/pyilmbase-2.5.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit cmake python-single-r1
+
+DESCRIPTION="IlmBase Python bindings"
+HOMEPAGE="https://www.openexr.com"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/25"
+KEYWORDS="~amd64 ~x86"
+IUSE="exceptions +numpy test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ ~media-libs/ilmbase-${PV}:=
+ sys-libs/zlib
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.62.0-r1:=[python,${PYTHON_MULTI_USEDEP}]
+ numpy? ( >=dev-python/numpy-1.10.4[${PYTHON_MULTI_USEDEP}] )
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-admin/chrpath
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/openexr-${PV}/PyIlmBase"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch
+)
+
+DOCS=( README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Python2=ON
+ -DPYILMBASE_INSTALL_PKG_CONFIG=ON
+ -DPYIMATH_ENABLE_EXCEPTIONS=$(usex exceptions)
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ if use numpy; then
+ python_domodule "${BUILD_DIR}/${EPYTHON/./_}/imathnumpy.so"
+ chmod +x "${D}/$(python_get_sitedir)/imathnumpy.so" || die
+ chrpath -d "${D}/$(python_get_sitedir)/imathnumpy.so" || die
+ fi
+}