summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2020-07-05 13:48:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-21 20:58:25 +0200
commite1d23133e46f11af2ff522f584aa1ab21a04443a (patch)
tree4b4f52236a4e5c7122f965509718e8f364af177a /dev-python/pyilmbase
parentmedia-libs/openexr: bump to 2.5.2 (diff)
downloadgentoo-e1d23133e46f11af2ff522f584aa1ab21a04443a.tar.gz
gentoo-e1d23133e46f11af2ff522f584aa1ab21a04443a.tar.bz2
gentoo-e1d23133e46f11af2ff522f584aa1ab21a04443a.zip
dev-python/pyilmbase: bump to 2.5.2
Remove support for python2.7 and add python-3 support. Closes: https://bugs.gentoo.org/711456 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/pyilmbase')
-rw-r--r--dev-python/pyilmbase/Manifest1
-rw-r--r--dev-python/pyilmbase/files/pyilmbase-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch30
-rw-r--r--dev-python/pyilmbase/metadata.xml10
-rw-r--r--dev-python/pyilmbase/pyilmbase-2.5.2.ebuild77
4 files changed, 117 insertions, 1 deletions
diff --git a/dev-python/pyilmbase/Manifest b/dev-python/pyilmbase/Manifest
index e99c4ca8492f..7d556826e89b 100644
--- a/dev-python/pyilmbase/Manifest
+++ b/dev-python/pyilmbase/Manifest
@@ -1 +1,2 @@
DIST pyilmbase-2.3.0.tar.gz 524975 BLAKE2B 7c3114921392ad29198025c672c366e6c98d2da968ed213ccfb446533b81fae4b78c687aba2108e476e16c4e97f11924799d0b0474ff3f82f17632f886bb6a39 SHA512 c20c26155315f2ae38efc183e5f33e2c18610365f5f1bca7a50363a005ff91c8782177293290ea037cf5f164f9b404f5710ce3cccba862e5e7f830727753589f
+DIST pyilmbase-2.5.2.tar.gz 27525326 BLAKE2B c48a61513457f2c04f3a512963ae27eaf154933ffe7c6ff3e2d71f27f246ae624a34dbe6f8ab500c51a56898ad0f61e6784f5cd3f9c3df591ce347b46ba4ac88 SHA512 62f98695cf56600303db9c2d13d34cacc1851a103d8ffb7e7ce8c6d9d14e6bf02804836c718ae03e8d685ef3dda0cf7b2130e2d363f8095b22a15bf30d706fab
diff --git a/dev-python/pyilmbase/files/pyilmbase-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch b/dev-python/pyilmbase/files/pyilmbase-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch
new file mode 100644
index 000000000000..6e8eb30cc474
--- /dev/null
+++ b/dev-python/pyilmbase/files/pyilmbase-2.5.2-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch
@@ -0,0 +1,30 @@
+From 34b8fd05781b61ce06263cdd22866a8bfc4be5b5 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Fri, 3 Jul 2020 22:01:18 +0200
+Subject: [PATCH] Fix pkgconfig file for PyIlmBase to include prefixes
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ config/CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/config/CMakeLists.txt b/config/CMakeLists.txt
+index 1872c89..44a9f2f 100644
+--- a/config/CMakeLists.txt
++++ b/config/CMakeLists.txt
+@@ -15,9 +15,9 @@ if(PYILMBASE_INSTALL_PKG_CONFIG)
+ # use a helper function to avoid variable pollution, but pretty simple
+ function(pyilmbase_pkg_config_help pcinfile)
+ set(prefix ${CMAKE_INSTALL_PREFIX})
+- set(exec_prefix ${CMAKE_INSTALL_BINDIR})
+- set(libdir ${CMAKE_INSTALL_LIBDIR})
+- set(includedir ${CMAKE_INSTALL_INCLUDEDIR})
++ set(exec_prefix "\${prefix}")
++ set(libdir "\${exec_prefix}/${CMAKE_INSTALL_LIBDIR}")
++ set(includedir "\${exec_prefix}/${CMAKE_INSTALL_INCLUDEDIR}")
+ set(LIB_SUFFIX_DASH ${OPENEXR_LIB_SUFFIX})
+ string(REPLACE ".in" "" pcout ${pcinfile})
+ configure_file(${pcinfile} ${CMAKE_CURRENT_BINARY_DIR}/${pcout} @ONLY)
+--
+2.27.0
+
diff --git a/dev-python/pyilmbase/metadata.xml b/dev-python/pyilmbase/metadata.xml
index 73126d2e6640..e5f54c42ad19 100644
--- a/dev-python/pyilmbase/metadata.xml
+++ b/dev-python/pyilmbase/metadata.xml
@@ -11,6 +11,14 @@
</maintainer>
<longdescription>Provides python bindings for <pkg>media-libs/ilmbase</pkg></longdescription>
<use>
- <flag name="numpy">Add bindings for <pkg>dev-python/numpy</pkg> use.</flag>
+ <flag name="exceptions">
+ Enable runtime floating point exceptions in PyIMath.
+ </flag>
+ <flag name="numpy">
+ Add bindings for <pkg>dev-python/numpy</pkg> use.
+ </flag>
</use>
+<upstream>
+ <remote-id type="github">AcademySoftwareFoundation/openexr</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/dev-python/pyilmbase/pyilmbase-2.5.2.ebuild b/dev-python/pyilmbase/pyilmbase-2.5.2.ebuild
new file mode 100644
index 000000000000..0411b0530d8d
--- /dev/null
+++ b/dev-python/pyilmbase/pyilmbase-2.5.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# boost is lacking py39 support as of 20200605
+PYTHON_COMPAT=( python3_{6,7,8} )
+CMAKE_ECLASS=cmake
+inherit cmake-multilib python-r1
+
+DESCRIPTION="IlmBase Python bindings"
+HOMEPAGE="https://www.openexr.com"
+SRC_URI="https://github.com/AcademySoftwareFoundation/openexr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/25"
+KEYWORDS="~amd64 ~x86"
+IUSE="exceptions +numpy test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/boost-1.62.0-r1:=[python,${MULTILIB_USEDEP},${PYTHON_USEDEP}]
+ ~media-libs/ilmbase-${PV}:=[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ numpy? ( >=dev-python/numpy-1.10.4[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/openexr-${PV}/PyIlmBase"
+
+PATCHES=(
+ "${FILESDIR}/${P}-0001-Fix-pkgconfig-file-for-PyIlmBase-to-include-prefixes.patch"
+)
+
+DOCS=( README.md )
+
+multilib_src_prepare() {
+ cmake_src_prepare
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ python_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Python2=ON
+ -DPYILMBASE_INSTALL_PKG_CONFIG=ON
+ -DPYIMATH_ENABLE_EXCEPTIONS=$(usex exceptions)
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DPython3_INCLUDE_DIR=$(python_get_includedir)
+ -DPython3_LIBRARY=$(python_get_library_path)
+ )
+ cmake_src_configure
+ }
+ python_foreach_impl python_configure
+}
+
+multilib_src_compile() {
+ python_foreach_impl cmake_src_compile
+}
+
+multilib_src_install() {
+ python_install() {
+ cmake_src_install
+ if use numpy; then
+ python_domodule "${BUILD_DIR}/${EPYTHON/./_}/imathnumpy.so"
+ chmod +x "${D}/$(python_get_sitedir)/imathnumpy.so" || die
+ fi
+ }
+ python_foreach_impl python_install
+}
+
+multilib_src_test() {
+ python_foreach_impl cmake_src_test
+}