summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-09 08:52:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-09 09:07:49 +0100
commit2ea8ba11b1f71da9b534bdd64e6183b26fc1c769 (patch)
tree2452f507e3288caf14ecf7dfbc427a2599da725c /dev-python/pykerberos/pykerberos-1.3.1.ebuild
parentdev-python/setuptools: Bump to 51.1.2 (diff)
downloadgentoo-2ea8ba11b1f71da9b534bdd64e6183b26fc1c769.tar.gz
gentoo-2ea8ba11b1f71da9b534bdd64e6183b26fc1c769.tar.bz2
gentoo-2ea8ba11b1f71da9b534bdd64e6183b26fc1c769.zip
dev-python/pykerberos: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pykerberos/pykerberos-1.3.1.ebuild')
-rw-r--r--dev-python/pykerberos/pykerberos-1.3.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pykerberos/pykerberos-1.3.1.ebuild b/dev-python/pykerberos/pykerberos-1.3.1.ebuild
new file mode 100644
index 000000000000..3d38c51c870d
--- /dev/null
+++ b/dev-python/pykerberos/pykerberos-1.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+MY_P=PyKerberos-${PV}
+DESCRIPTION="A high-level Python wrapper for Kerberos/GSSAPI operations"
+HOMEPAGE="
+ https://www.calendarserver.org/PyKerberos.html
+ https://github.com/apple/ccs-pykerberos/
+ https://pypi.org/project/kerberos/"
+SRC_URI="
+ https://github.com/apple/ccs-pykerberos/archive/${MY_P}.tar.gz"
+S=${WORKDIR}/ccs-pykerberos-${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+# test environment is non-trivial to set up, so just use docker
+# (see python_test below)
+# also for alpha/beta Python releases support:
+# https://github.com/apple/ccs-pykerberos/pull/83/commits/5f1130a1305b5f6e7d7d8b41067c4713f0c8950f
+RESTRICT="test"
+
+RDEPEND="app-crypt/mit-krb5"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ set -- docker run \
+ -v "${PWD}:/app" \
+ -w /app \
+ -e PYENV=$("${EPYTHON}" -c 'import sys; print(sys.version.split()[0])') \
+ -e KERBEROS_USERNAME=administrator \
+ -e KERBEROS_PASSWORD=Password01 \
+ -e KERBEROS_REALM=example.com \
+ -e KERBEROS_PORT=80 \
+ ubuntu:16.04 \
+ /bin/bash .travis.sh
+ echo "${@}" >&2
+ "${@}" || die "Tests failed with ${EPYTHON}"
+}