summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 09:06:28 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 09:18:51 +0100
commitbd0cd8a7848b21572e811d8798e9e96516a871e5 (patch)
treefacb83388c2bf92da2394b14db5ab3ab7a9ade83 /dev-python/pylibacl
parentmail-mta/msmtp: amd64 stable wrt bug #757135 (diff)
downloadgentoo-bd0cd8a7848b21572e811d8798e9e96516a871e5.tar.gz
gentoo-bd0cd8a7848b21572e811d8798e9e96516a871e5.tar.bz2
gentoo-bd0cd8a7848b21572e811d8798e9e96516a871e5.zip
dev-python/pylibacl: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylibacl')
-rw-r--r--dev-python/pylibacl/Manifest1
-rw-r--r--dev-python/pylibacl/pylibacl-0.6.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pylibacl/Manifest b/dev-python/pylibacl/Manifest
index 3100c2755e0d..468d71210f08 100644
--- a/dev-python/pylibacl/Manifest
+++ b/dev-python/pylibacl/Manifest
@@ -1,2 +1,3 @@
DIST pylibacl-0.5.4_p20191217.tar.gz 40283 BLAKE2B dfe5baababe4cce24bc12dd61263c30160e93be7dc0625abdcad9e4daed19c5ac1ebf43351f9f5815884162258884cd8c7e2edb323ec9ce51247a43d53fea20e SHA512 6d4a84e1885a2000226f956580a8e767216d6280d4b8ae1066e6a1c1f82708d06a4f2eacc3ae45ff7ae3b122125da9fb6afbaae038e117b63cd7d91ac95e2624
+DIST pylibacl-0.6.0.gh.tar.gz 40231 BLAKE2B ba76f5540de62cec8572960b65f65289d7fe2066f76861240849c4c8175a9219b7ced086739b5a9b4d560a125c8fe759cc7b5b688bd4dc3d84ca4dc78897ea75 SHA512 a93ad199d9946490a863906411893a204bf801df71cf70217d6b29940a9365f05fd121116f22e054a3b8d27cd62e35c73566c1e0dd246ae5c0edd2f967df50ba
DIST pylibacl-v0.5.3.tar.gz 32792 BLAKE2B 005785dda2b7933ff71dd1296b1d4315a6492fc893aba56136c775f78b9aa3bd8f9d4898bbe0160fac53a306329977ddaecd073739531ba42dd0b6cc622b9eef SHA512 ea648acc3df9e1cf2fd68576b0b691a353b257d00b74fc80aa7f60089b9dbc912452ebe6b84da2930cac888b9047740530dd0e38b4d5be52c37fc6d3a29a7ce2
diff --git a/dev-python/pylibacl/pylibacl-0.6.0.ebuild b/dev-python/pylibacl/pylibacl-0.6.0.ebuild
new file mode 100644
index 000000000000..5b4469c6178c
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
+HOMEPAGE="
+ https://pylibacl.k1024.org/
+ https://pypi.org/project/pylibacl/
+ https://github.com/iustin/pylibacl/"
+SRC_URI="
+ https://github.com/iustin/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="sys-apps/acl"
+DEPEND=${RDEPEND}
+
+distutils_enable_tests pytest
+
+python_test() {
+ if ! pytest -vv; then
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ die "Tests fail with ${EPYTHON}"
+ fi
+}