summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-30 13:09:32 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-30 13:09:32 +0200
commit0da74d978ec2eee99d14770630febcae8ececa0d (patch)
tree34519965b19bacf3d2e5b0d96d04492c36082552 /dev-python/pylint
parentdev-python/inflect: Remove old (diff)
downloadgentoo-0da74d978ec2eee99d14770630febcae8ececa0d.tar.gz
gentoo-0da74d978ec2eee99d14770630febcae8ececa0d.tar.bz2
gentoo-0da74d978ec2eee99d14770630febcae8ececa0d.zip
dev-python/pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/files/pylint-2.5.3-tests.patch12
-rw-r--r--dev-python/pylint/pylint-2.6.2.ebuild64
3 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 00af651eb242..bfbf0cdc5707 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,3 +1,2 @@
-DIST pylint-2.6.2.tar.gz 680364 BLAKE2B 59bd18d5458f86a7279a7fc895f1564fc575c27e7ad7b4a668456d6005cc2a4d920e2221c2ec3f447c1c63376e1b35f1e1c5177c355f52872d3c556aa63ae462 SHA512 75e88aea23e4e68714451d22b0a6a2106a4821c05cdd7d077e12ea7f6198959ebdace6824b1e2fb42a632051e049a2c84eb93990a7b6af23c7fee7e2f56bf6ec
DIST pylint-2.7.1.tar.gz 708916 BLAKE2B 606637ff25daccba741ae5bcdecb6a2be50bc17393009193a29312b4a218622d23287a0f0c5a81e79e77cc54dfe529483ad01fa39445103f240addaa3ad58bf7 SHA512 eebf1d3da5ca072cb912ecffebf183c79f2f8b2c2b14044751aad202d75d06d1c06abb561d4581990b92fe54c06b570a1de39b792b0d729cf300c01c82c4e3c0
DIST pylint-2.7.2.tar.gz 709177 BLAKE2B 5e4daeb19b6b18d570f4d78b01cc5023d5d245840160fdbddb194ab7036118742ffe3075ee27c37bd7a700d11d9006dc9abaaba9cf9596ae1b63941f139da7ac SHA512 800b210fbe5665db390d5c885d103856dc474b4e43d2f752bdcfcea36121132c26eecdcb67620c4a90456823f11a33568de4d37d59eea692dcd1751d931420f7
diff --git a/dev-python/pylint/files/pylint-2.5.3-tests.patch b/dev-python/pylint/files/pylint-2.5.3-tests.patch
deleted file mode 100644
index 72a42e4caaeb..000000000000
--- a/dev-python/pylint/files/pylint-2.5.3-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/tests/test_self.py b/tests/test_self.py
-index 6c27fd6c..9fde0214 100644
---- a/tests/test_self.py
-+++ b/tests/test_self.py
-@@ -686,6 +686,7 @@ class TestRunTC:
- )
-
- @staticmethod
-+ @pytest.mark.skip("seems to be failing to import nonexistant module")
- def test_do_not_import_files_from_local_directory(tmpdir):
- p_astroid = tmpdir / "astroid.py"
- p_astroid.write("'Docstring'\nimport completely_unknown\n")
diff --git a/dev-python/pylint/pylint-2.6.2.ebuild b/dev-python/pylint/pylint-2.6.2.ebuild
deleted file mode 100644
index 387a8d2c4933..000000000000
--- a/dev-python/pylint/pylint-2.6.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Not ready for Python 3.9 yet: https://github.com/PyCQA/pylint/issues/3895
-PYTHON_COMPAT=( python3_{7..8} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="https://www.logilab.org/project/pylint
- https://pypi.org/project/pylint/
- https://github.com/pycqa/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86"
-IUSE="examples"
-
-# Mirror requirements from pylint/__pkginfo__.py
-RDEPEND="
- >=dev-python/astroid-2.4.0[${PYTHON_USEDEP}]
- <dev-python/astroid-2.5[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
- >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/six[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
- "${FILESDIR}/${PN}-2.5.3-tests.patch"
-)
-
-distutils_enable_sphinx doc --no-autodoc
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # we don't want to run the benchmarking tests
- rm -f tests/benchmark/test_baseline_benchmarks.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}